After upgrading VMware Aria Suite Lifecycle 8.12 to 8.14 the Build and Version numbers are not updated
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After upgrading VMware Aria Suite Lifecycle 8.12 to 8.14 the Build and Version numbers are not updated

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Article ID: 337199

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • After upgrading VMware Aria Suite Lifecycle to 8.14, under Lifecycle Operations > Settings > System Details page and about section of the UI, the build number and version is not updated.
  • Product Support Pack shows 8.14.0.4 version, but all other places show older version.


Environment

VMware Aria Suite Lifecycle 8.x

Cause

The issue occurs when a number of post upgrade scripts fail to execute.

Resolution

This issue is resolved in VMware Aria Suite Lifecycle 8.12 Patch 2. See VMware Aria Suite Lifecycle 8.12 Patch 2 Release Notes for additional information.

Note: To avoid encountering this issue when upgrading to 8.14, it is recommended to first apply 8.12 Patch 2, otherwise, see the Workaround below for additional information.

Workaround:

The available workarounds depend upon whether or not a pre-upgrade snapshot is available.

Note: Snapshots should always be taken before any significant change or upgrade.

If a pre-upgrade snapshot exists

  1. Revert to pre-upgrade snapshot.
  2. Create a file titled /var/log/bootstrap/fips_disable:
    touch /var/log/bootstrap/fips_disable
  3. Set the permissions on the file:
    chmod 644 /var/log/bootstrap/fips_disable
  4. Retry the upgrade.

Note: You may run these steps before any upgrade attempt to prevent this issue from occurring.

If a pre-upgrade snapshot does not exist follow these steps

In such cases when after the upgrade the UI shows no details of the upgraded version, these are the steps to fix the appliance.

  1. Take a snapshot of VMware Aria Suite Lifecycle appliance. 
  2. SSH to VMware Aria Suite Lifecycle appliance using root credentials. 
  3. Run the following commands.
    /etc/bootstrap/postupdate.d/26-cleanup-pspak-db-backups && /etc/bootstrap/postupdate.d/27-fill-cap-product-info && /etc/bootstrap/postupdate.d/60-update-upgrade-status && /etc/bootstrap/postupdate.d/70-blackstone-upgrade.sh && /etc/bootstrap/postupdate.d/80-cleanup-patch-history && /etc/bootstrap/postupdate.d/90-enable-fips-mode && /etc/bootstrap/postupdate.d/91-create-cap-update-settings && /etc/bootstrap/postupdate.d/92-disable-vami-lighttpd
  4. Restart the cap service.
    systemctl restart cap-workflow-engine.service
  5. Edit the file /etc/vmware/cap/cap_am/update_status.json to reflect the values in the JSON below:
    {"state":"UP_TO_DATE","version":"","latest_query_time":"<do-not-change-the-value>","instance_id":"<do-not-change-the-value>","current_workflow":"cap-non-lvm-update","progress":"100%","message":"Completed","status":"Completed"}
  6. Edit the file /etc/upgradeinfo

Note: The entry should be similar to:

Upgrade Completed Successfully from 8.2.0.23 to 8.10.0.6 on 1665243746
Upgrade Completed Successfully from 8.10.0.6 to 8.12.0.7 on 1687777307
Upgrade Completed Successfully from  to  on 1697732933
Update it to:
Upgrade Completed Successfully from 8.2.0.23 to 8.10.0.6 on 1665243746
Upgrade Completed Successfully from 8.10.0.6 to 8.12.0.7 on 1687777307
Upgrade Completed Successfully from 8.12.0.7 to 8.14.0.4 on 1697732933
Note: Do not change the timestamp of the last entry, only update the correct versions.
  1. Edit the file /etc/vmware/cap/product.info, it may have the version missing. Update the version similar to:
    {     "product_name": "VMware Aria Suite Lifecycle Appliance",     "version": "8.14.0.4",     "build_number": "22630472" }
  2. Run the following command and wait for the UI to restart.
    /etc/bootstrap/postupdate.d/99-reboot-va
  3. Validate that the build version is now visible in Lifecycle Operations > Settings > System Details page and About section of the UI.
Note: For a VCF aware vRSLCM environment, additional steps may be needed to reflect the build number in SDDC Manager database. Please follow https://kb.vmware.com/s/article/95790 to fix the issue in SDDC Manager inventory.

Additional Information

Impact/Risks:
Upgrade remains incomplete if not resolved.