HCX-Connector or Cloud Manager UI inaccessible after restoring a backup
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HCX-Connector or Cloud Manager UI inaccessible after restoring a backup

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Article ID: 314208

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Updated On:

Products

VMware HCX

Issue/Introduction

Identify a known issue with the backup and restore feature in HCX AUI


Symptoms:
The HCX Connector or Cloud Manager may become inaccessible after restoring a backup using the HCX AUI Backup and Restore feature.

Cause

The backup process fails to preserve vCenter information used for access.
This issue only affects HCX versions 4.1.X and 4.2.X.

Resolution

Do NOT restore any backup generated with ANY affected version otherwise redeployment may be required.
The issue is resolved in HCX version 4.3.0
Refer to the Release Notes .

Workaround:
Alternatively, the VMware snapshot feature can be used to preserve the state of the system right before the software upgrade. In the unlikely event of a problem after an upgrade, the HCX Connector or Cloud Manager VM can be reverted to the last snapshot.

NOTE: VMware snapshot feature is not intended to be used as a long-term backup solution for any VM.

Additional Information

vSphere Snapshot Best Practices
KB 86462 Unable to upgrade HCX Connector or Cloud Manager after reverting a snapshot

Impact/Risks:
After restoring a backup, all content that has a dependency on the vCenter inventory will not be accessible through the HCX standalone UI nor the vCenter plug-in therefore no migration or configuration workflows can be performed.
Network Extension services will remain active but no configuration changes can be done.