Error on VCSA Console after Applying Update Patch "vmdir.password is not set; aborting installation" or "Failed to Configure Network"
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Error on VCSA Console after Applying Update Patch "vmdir.password is not set; aborting installation" or "Failed to Configure Network"

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Article ID: 322802

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
After successfully applying update patch to vCenter Server appliance 7.x, an error message is shown on the VM console -
"vmdir.password is not set; aborting installation" or "Failed to Configure Network"

Environment

VMware vCenter Server 7.0.x

Cause

The cap first boot service RPM no longer exists in 70u2 and higher build update bundles. The upgrade scripts contain a bug which attempts to run the RPM and fails on update firstboot.
There are no functional impacts on vCenter. This issue will be resolved in future releases.

Resolution

Use the following steps as a workaround to resolve the message:

1. Delete/move the file /etc/vmware/cap/cap-firstboot.sh (removing this file will prevent the issue from occurring in the future)
     - mv /etc/vmware/cap/cap-firstboot.sh /tmp

2. Delete/move the file /var/log/firstboot/failed
     - mv /var/log/firstboot/failed /tmp

3. Create a new file "succeeded" under the directory /var/log/firstboot
     - touch /var/log/firstboot/succeeded

4. Take a backup of rpmInstall.json file
     - cp /var/log/firstboot/rpmInstall.json /var/log/firstboot/rpmInstall.json.BAK

5. Replace contents of /var/log/firstboot/rpmInstall.json with below:

{
  "progress": 100,
  "question": null,
  "status": "success",
  "progress_message": {
    "localized": "",
    "translatable": ""
  },
  "error": null,
  "warning": [],
  "start_time": "2021-06-13T14:28:50.278Z",
  "info": [],
  "end_time": "2021-06-13T14:47:07.972Z"
}
Start and End times may be set to estimated date the upgrade occurred.

If the message still shows on the console, execute the /usr/lib/applmgmt/dcui/notify script to immediately remove the message from DCUI.


Workaround:
To prevent the issue from occurring:

If planning to update from 70U2 or if already updated but have yet to reboot the vCenter appliance, delete the file /etc/vmware/cap/cap-firstboot.sh following the steps below:

1. Login into putty/ssh session to VC
2. Delete the file /etc/vmware/cap/cap-firstboot.sh