Update WS1A sshuser password for WS1A deployed in VCF mode
search cancel

Update WS1A sshuser password for WS1A deployed in VCF mode

book

Article ID: 312167

calendar_today

Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Symptoms:
1. Password update of the sshuser is not supported in VCF and disabled in vRSLCM
2. When the password is expired - Inventory sync for WS1A environment in vRSLCM fails with "Unable to verify SSH user's password. Ensure the password is not already expired and retry after providing valid credentials".

Environment

VMware Cloud Foundation 4.2
VMware Cloud Foundation 4.0.x
VMware Cloud Foundation 4.x
VMware Cloud Foundation 4.1

Cause

sshuser password management is disabled when vRSLCM is in VCF mode.

Resolution

This is a known issue. Vmware is working on the fix.

Workaround:
  1. Login to the vIDM appliance directly creating an ssh connection and update the expired password. For more information seeĀ How to reset the admin password in VMware Identity Manager (you have to run passwd sshuser).
  2. Create locker entry for the new password in vRSLCM.
  3. Run inventory sync in vRSLCM, which would be failing(Since vRSLCM would not be aware of the password which is being set outside vRSLCM). Please note in the case of clustered vIDM, the same task would be checking the passwords of all the 3 nodes, hence provide the right password by looking at the hostname and user name for which the request failed. On 3rd wrong attempt, the vIDM password would get locked.
  4. Retry the failed inventory sync request in vRSLCM, choosing the locker entry of the new password created in above step 2.