Backing up a Native Key Provider fails when accessing via IP
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Backing up a Native Key Provider fails when accessing via IP

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Article ID: 318384

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Updated On:

Products

VMware Aria Suite VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Attempting to back up a Native Key Provider when accessing vCenter using IP address instead of FQDN fails silently
  • The key provider remains in "Not backed up" state


Environment

VMware vSphere 7.0.x

Cause

This issue is caused because of browser security. The browser checks the origin of the code that generates the backup file and compares it with the URL. This does not match because one uses FQDN, and the other uses an IP.

Resolution

This is a known issue affecting vCenter Server 7.0 U2 and is resolved in 7.0 U3.

Workaround:
To workaround this issue, access vCenter using a fully qualified domain name instead of IP address.

Additionally, if the Hostname within the VAMI is short, update the hostname to FQDN.
  1. Access the vCenter's VAMI page on port 5480 via root.
  2. On the left-hand side panel, navigate to the Networking section.
  3. In the Network Settings view, click on Edit at the top right.
  4. In the Edit Network Settings wizard:
    1. Select Network Adapter > Select the appropriate Management Network NIC > Click Next.
    2. Edit settings > Update the Hostname from short to FQDN > Click Next.
    3. SSO credentials > Enter in the SSO administrator credentials > Click Next. 
    4. Ready to complete > Review the settings before completing the wizard > Check the box to acknowledge > Click Finish.
      • Note: Reconfiguring the NIC 0 management network adapter will result in downtime of your vCenter Server and can take some time before it is up and running again.