Skyline Health Diagnostics UI is not accessible after deploying Appliance Version 2.0.5-17790475
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Skyline Health Diagnostics UI is not accessible after deploying Appliance Version 2.0.5-17790475

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Article ID: 323346

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • UI page is not accessible on a newly deployed Skyline Health Diagnostics appliance version 2.0.5 (VMware-Skyline-HealthDiagnostics-Appliance-2.5.0-17790475_OVF10.ova)
  • Console login as root user using the deploy time password fails
  • Appliance is not accessible over SSH


Environment

VMware vSphere 7.0.x
VMware vSphere 6.7.x
VMware vSphere 6.5.x

Cause

The build time root password is expired and first boot fails to initialize the application correctly.

Resolution

To resolve this issue, the root password needs to be changed and a manual run of first boot is required.

Apply the steps below to get the Skyline Health Diagnostics appliance set up correctly:
  1. Deploy Appliance using OVA (VMware-Skyline-HealthDiagnostics-Appliance-2.5.0-17790475_OVF10.ova) via vCenter Server.
  2. After the deployment is complete, Power on the Appliance 
  3. Wait for 5 minutes
  4. Check if the UI is accessible. If yes, you can start using the appliance and skip steps 5-10
  5. Open the appliance console using Web Console or Remote Console in the vSphere Client
  6. In the Appliance console, log in as the root user with password vmware
  7. You will be asked to change the password
  8. Follow the password change steps. (Use vmware as current password)
    • Use a temporary password here. Don't use the deploy time password
    • This password will be changed again by first boot script to the one your provided during deploy time
  9. Once the password is changed, on the command prompt run the following commands:
    • rm -rf /opt/vmware-shd 
    • sh /etc/vmware/cap/cap-firstboot.sh  
  10. After the first boot script has run, log in to the UI using the Browser
    1. If you see the Password Manager Screen, complete the password change and let the appliance reboot. Please use the passwords used during initial deployment of the appliance as value for the current passwords.
    2. After reboot you are able to access the regular SHD UI