Network not found error after upgrading to VMware Identity Manager 3.3.4 to 3.3.5
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Network not found error after upgrading to VMware Identity Manager 3.3.4 to 3.3.5

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Article ID: 336785

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
After upgrading VMware Identity Manager, you experience this symptom:

You experience a network lost error

Affected versions:
  • From version 3.3.2/3.3.3/3.3.4 to 3.3.5 upgrade
  • From version 3.3.2/3.3.3 to 3.3.4 upgrade


Environment

VMware Identity Manager 3.3.x

Cause

This issue occurs due to missing multiple OVF properties.

To understand the cause:
  1. Run this command from the appliance:

    /opt/vmware/bin/ovfenv
     
  2. Check the value of the OVF properties from the output:

    [vami.DNS.IdentityManager]=
    [vami.domain.IdentityManager]=
    [vami.gateway.IdentityManager]=
    [vami.hostname]=
    [vami.ip0.IdentityManager]=
    [vami.netmask0.IdentityManager]=
    [vm.vmname]=
    It should be something similar to below
    [vami.DNS.IdentityManager]=10.142.28.1
    [vami.domain.IdentityManager]=hs.trcint.com
    [vami.gateway.IdentityManager]=10.143.111.253
    [vami.hostname]=sva-kn3.hs.trcint.com
    [vami.ip0.IdentityManager]=10.143.104.223
    [vami.netmask0.IdentityManager]=255.255.248.0
    [vm.vmname]=IdentityManager

     
  3. If any of the properties is empty or incorrect, apply these steps to resolve the issue:

    Here is a sample incorrect wrong OVF property values which could lead to network not found issue post upgrade:

    "/opt/vmware/bin/ovfenv" could show "Unable to find the ovf environment."
    "/usr/local/horizon/scripts/networkwizard.hzn showovfenv" could show as below
    Detect ovfenv
    OVFENV_OK=
    OVFENV_NET_HOSTNAME=

Resolution

To resolve this issue:
  1. Shutdown the appliance.
  2. Edit the vApp Options from the vCenter Server (documentation) to update the values with the correct entries.
  3. Power on the appliance.
  4. The network should now come up.