Troubleshooting vCenter Appliance /storage/log directory is 80% or more full
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Troubleshooting vCenter Appliance /storage/log directory is 80% or more full

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Article ID: 313077

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

This article provides information on how to troubleshoot and resolve the /storage/log partition being full on vCenter Appliance.

Symptoms:
  • vCenter Server Appliance (vCSA) reports errors similar to:
    • vSphere UI Health Alarm", "Log disk exhaustion on vcenter name
    • Database Health Alarm", "Core and Inventory Disk Exhaustion on vcenter name
  • vCenter Server may be inaccessible with 503 Service Unavailable errors.
  • vSphere Appliance Management Interface (VAMI) Monitor > Disk shows /storage/log at 75% full or more:
    • At 75% of continuous disk use the space will trigger Yellow status warnings
    • At 85% the space will trigger Red critical alarms
    • At 95% the vpxd service will shut down to prevent file and database corruption


Environment

VMware vCenter Server Appliance 6.0.x
VMware vCenter Server Appliance 6.7.x
VMware vCenter Server Appliance 6.5.x
VMware vCenter Server 8.0
VMware vCenter Server 7.0.x

Cause

Potential causes include:
  • vCenter Server log bundles not being cleared after generation
  • Very high frequency events filling up logs
  • Services such as the Apache Tomcat Java Servlet service failing to clean up files
  • /storage/log partition set too small

Resolution

  1. Verify whether one of these known issues is not causing the problem:
Affected VersionsAssociated Knowledgebase Article link
6.0
6.0 before Update 3, 6.5 before Update 1
7.0 before Update 1C
7.0 before Update 3c
7.0 before Update 3o, 8.0 before Update 1
7.0, 8.0, not resolved in any newer version

7.0 Update 1 through Update 2.
Fixed in Update 3

7.0 Update 1 and newer releases. Fixed in 8.0.
7.0 Update 2. Fixed in Update 3.
All versions
 
  1. If the known issues don't identify the problem, look for excessive Tomcat log files in the partition.
    1. Connect to the vCenter Server Appliance through SSH or through the vCenter VM console
    2. Type shell to switch to the BASH shell
for more information about enable or disable SSH ad Bash shell access, refer Enable or Disable SSH and Bash Shell Access
  1. U​​​​​​se the following command to list the Apache Tomcat service log files under the below paths:
/storage/log/vmware/sso/tomcat/
/storage/log/vmware/eam/web/
/storage/log/vmware/lookupsvc/tomcat/ (vCenter 7.0 only)
  1. If there are a lot of these you may delete them to free up space
ls -lha catalina*log
rm catalina*log
  1. Check whether space has significantly improved or not. If it has, the drive might be too small for the log traffic. You might increase the size of the /storage/log virtual disk per vCenter Server Appliance disk space is full
df -h
  1. Check for and remove excessive PostgreSQL service health alarm log files
    1. In  /storage/log/vmware/sso/tomcat/, /storage/log/vmware/eam/web/ & /storage/log/vmware/lookupsvc/tomcat/ (vCenter 7.0 only) directories, run the commands:
ls -lha localhost_access*
rm localhost_access*
  1. Check again whether space has significantly improved or not. If it has, the drive might be too small for the log traffic. You might increase the size of the /storage/log virtual disk per vCenter Server Appliance disk space is full
  1. Check for and remove excessive Storage Profile Service access logs
cd /var/log/vmware/vmware-sps
ls -lha sps-access*log
rm sps-access*log
 
Check again whether space has significantly improved or not. If it has, the drive might be too small for the log traffic. You might increase the size of the /storage/log virtual disk per vCenter Server Appliance disk space is full
  1. If the previous steps did not Identify the problem, follow vCenter Server Appliance disk space is full in the "Further troubleshooting" section. 
Warning: Before deleting any files from the vCenter Appliance, ensure you have a good backup of vCenter


Additional Information

vCenter Server Appliance disk space is full
vCenter Server /storage/log filling up due to localhost_access.log and catalina.log in sso and lookupsvc log directories

Impact/Risks:
Under default settings, when the partition reaches 75% full of continuous disk use for at least 10 minutes:
  • You will see alarms being triggered.
When the partition reaches 95% full at any point
  • The operating system will prevent the main vmware-vpxd service from starting to try to prevent file corruption.
Please keep in mind that this does not require it to be at 95% for a continuous period so the threshold might be crossed, shut down vpxd service, and then the use may recede,
Deleting critical files may prevent the vCenter Server Appliance from working.
Resizing vCenter Appliance virtual disks carries the risk of data corruption.
 
WARNING:
Ensure you have a good backup of vCenter Appliance before deleting files or resizing disks.