[VMC on AWS] Warning alert message “Failed login to vSphere ESX Agent Manager”
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[VMC on AWS] Warning alert message “Failed login to vSphere ESX Agent Manager”

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Article ID: 329753

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

Symptoms:
i. "Failed login to vSphere ESX Agent Manager" warning alert message is seen by User "com.vmware.vim.eam" under the Events tab of the vCenter console. 

ii. An example of this warning message is as follows:


iii. In vRLIC (vRealize Log Insights Cloud), the alert message can be seen as follows:


ii. You may also observe notification such as "User session failed login" due to user EAM (ESX Agent Manager) if a custom alert is created using vRLIC to monitor any illegitimate user activity in your SDDC.

Cause

i. For all M9 + SDDC build versions, the NSX-T manager periodically checks EAM health with user authentication in the cookie. The above alert message is reported when the authentication in cookie is already expired.

Resolution

Warning alerts due to message "Failed login to vSphere ESX Agent Manager" can be safely ignored.

Workaround:
If you have created any custom alert (using vRLIC) to notify you regarding any illegitimate user activity and are getting multiple notifications due to the above alert message. Please consider modifying the custom alert such that it ignores any failed user login session due to an EAM user.

Additional Information

Impact/Risks:
There is no impact to customer's environment.