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Article ID: 315157
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Updated On:
Environment
VMware vCloud Availability 3.5.x
VMware Cloud Director Availability 4.x
VMware vCloud Availability 3.0.x
Cause
This issue occurs when there is a conflict between the snapshot management of the virtual machine by Cloud Director Availability and the snapshot based backup solution in the environment.
In most cases, the replication technology used by Cloud Director Availability does not utilize snapshots. However, in the case of Windows virtual machines, VSS can be utilized on the source virtual machine when quiescing is enabled, which does require the use of snapshots. This can interfere with snapshot based backups if there is an active replication during the backup collection and cause unexpected behavior with the normal backup process or with the health of the replication.
Resolution
This is a known issue impacting environments with Cloud Director Availability.
Workaround:
To mitigate the occurrence of these issues, you can perform one of the following options:
- Disable quiescing on the replications in question.
- Pause replication on the virtual machines during backups.
- Use a different backup strategy for the virtual machines.
With Windows Server 2019 virtual machines, you may also experience snapshot quiescing issues due to a known Microsoft VSS bug. For more information, see
Taking a quiesce snapshot of Windows Server 2019 virtual machine fails.
Additional Information
Pausing and resuming replications can be automated using the API. For more information, review the pause and review functions in the vm-replications namespace in the OpenAPI Client in Cloud Director Availability 4.0 and later or the Cloud Director Availability API reference on
VMware {code}.
Quiescing can introduce performance issues on virtual machines with high I/O requirements. Therefore, impacts to the source virtual machine should be taken in consideration before enabling quiescing. For more information, see
Best Practices for Using and Configuring vSphere Replication.