vAPI-Endpoint service health shows as Yellow in VAMI UI of vCenter Server Appliance 7.0
search cancel

vAPI-Endpoint service health shows as Yellow in VAMI UI of vCenter Server Appliance 7.0

book

Article ID: 322790

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • In the VAMI UI, the health status of vAPI-Endpoint service shows as "Healthy with warnings". The description of the status states: "Failed to connect to [uuid]\com.vmware.vcenter.nsxd.vapi vAPI provider"
  • In log file /var/log/vmware/vapi/endpoint/endpoint.log you see entries similar to:
2020-07-31T17:24:42.793Z | WARN  | state-manager1            | ApiInterfacesFactory           | Retrieving interfaces for service 8a17038f-65
2020-07-31T17:24:42.801Z | WARN  | state-manager1            | ApiInterfacesFactory           | The cache does not contain entry for service 8a17038f-6504-4830-ac6b-c7e9be79a98e\com.vmware.vcenter.nsxd.vapi. The interfaces will be skipped.
2020-07-31T17:24:42.802Z | INFO  | state-manager1            | HealthStatusCollectorImpl      | HEALTH YELLOW Failed to connect to 8a17038f-6504-4830-ac6b-c7e9be79a98e\com.vmware.vcenter.nsxd.vapi vAPI provider.
2020-07-31T17:24:42.893Z | INFO  | state-manager1            | DefaultStateManager            | Invoking vcenter-shim-service-builder
 
Note: The preceding log excerpts are only examples. Date, time and environmental variables may vary depending on your environment.


Environment

VMware vSphere 7.0.x

Cause

The vapi-endpoint service sees that there is the registration in Lookup Service and tries to connect to http://localhost:8920.nsxd which returns 404 page not found. This error sets the health status of the service to yellow because it does not have connection to one of its vapi providers.

Resolution

This issue is resolved in vCenter Server 7.0 Update 1, available at VMware Downloads.

Workaround:
This Warning message can be safely ignored, if immediate upgrade to vCenter Server 7.0 U1 is not possible.

Additional Information

VMware Skyline Health Diagnostics for vSphere - FAQ