Cisco Native FNIC (nfnic) driver may fail to properly relogin to fabric targets resulting in dead paths and/or APD
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Cisco Native FNIC (nfnic) driver may fail to properly relogin to fabric targets resulting in dead paths and/or APD

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Article ID: 318526

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
When performing storage array maintenance or any action that would cause an array target to go offline/online, the Cisco Native FNIC driver may not properly log back into the target resulting in paths remaining in a dead state

Environment

VMware ESXi 6.7.x
VMware vSphere ESXi 6.7

Cause

This issue is caused by the Cisco Native FNIC driver receiving an RSCN during the REPORT_LUNS command part of the nfnic port login process, which results in the driver halting and not retrying the login process. This was observed with both the IBM SVC and IBM V7000 array but it would also have been observed on any IBM Storwize array since they all use the same software stack. This would also be observed for non-IBM arrays as well, so long as they issue an RSCN during the REPORT_LUNS command that the drivers sends during login.

Resolution

This issue is resolved in Cisco Native FNIC (nfnic) driver version 4.0.0.63 for ESXi 6.7:

https://my.vmware.com/en/group/vmware/downloads/details?downloadGroup=DT-ESXI67-CISCO-NFNIC-40063&productId=742


Workaround:
The only workaround is to manually bounce the host fabric ports after the array target is fully logged into fabric as the RSCN shouldn't interrupt the REPORT_LUNS command at that point.

Additional Information

Cisco Links:

https://quickview.cloudapps.cisco.com/quickview/bug/CSCvs36209
https://quickview.cloudapps.cisco.com/quickview/bug/CSCvw24754