Import offline bundle or sync operations may fail in vSphere Lifecycle Manager
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Import offline bundle or sync operations may fail in vSphere Lifecycle Manager

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Article ID: 320199

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • The content of the offline bundle does not show up in Lifecycle Manager.
  • The Save or Validate operations with the image containing packages from Hardware Support Manager fail with a message similar to:

    Failed to fetch component information for hardware support package VMware ESXi 7.0 Upgrade Pack in the depot, Invalid hardware support spec specified in the draft
     
  • Importing offline bundle into vSphere Lifecycle Manager fails through the vSphere Web Client.
  • You see a message similar to:

    Error: 'integrity.fault.HostPatchInvalidVendorCode'
  • In the /var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server-log4cpp.log file, you see a message similar to:

    [2020-04-16 19:25:07:881 'HostUpdateDepotManager' 139788413433600 ERROR]  [metadataCache, 319] Invalid vendor code: <VENDOR CODE>, this conflicts with the existing code: <vendor code>. Invalid code is from URL:https://hostupdate.vmware.com/software/VUM/PRODUCTION/addon-main/addon/<VENDOR CODE>
    [2020-04-16 19:25:07:884 'VciSigUpdateTask.SigUpdateTask{11}' 139788413433600 ERROR]  [vciSigUpdateTask, 427] Error download ESX 4x updates from https://hostupdate.vmware.com/software/VUM/PRODUCTION/addon-main/vmw-depot-index.xml: <VENDOR CODE>
Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware vCenter Server 7.0.x
VMware vCenter Server 8.0.0

Cause

This issue occurs due to a mismatch in vendor codes (lower/upper case) in the online and offline content downloaded into the vSphere Lifecycle Manager. 

Note: This issue may appear in the instances of vCenter Server 7.0 installed (or upgraded to) between April 2nd and April 18th, 2020.

Resolution

Note: This issue is resolved on July 7th, 2020. Deployments and upgrades of vCenter Server 7.0 after July 7th 2020 are not impacted by this issue.

To resolve this issue:
  1. If you are using UMDS  (Update Manager Download Service) 7.0:

    i. Connect to UMDS appliance through SSH.
    ii. Download the attached file KB_78688_remove-umds-addon.sh file.
    iii. To clean up the UMDS patch store, copy the KB_78688_remove-umds-addon.sh to a location in the UMDS appliance.

    a. Change the permissions of the script by running this command:

    chmod +500 KB_78688_remove-umds-addon.sh

    b. Execute the script by running this command:

    ./KB_78688_remove-umds-addon.sh

    c. Re-download the content through UMDS by running this command:

    ./vmware-umds -D

    d. Remove (delete) all content from the UMDS export store repository.
     
  2. Connect to the vCenter Server Appliance 7.0 through SSH.
  3. Run this shell command to switch to the BASH Shell:

    shell
     
  4. Download the attached file KB_78688_remove-addon.sh.
  5. To clean up incorrect entities in the Lifecycle Manager database and restarting the Lifecycle Manager service:

    i. Copy the script KB_78688_remove-addon.sh to a location in  the vCenter Server Appliance.
    ii. Change the permissions of the script by running this command:

    chmod +500 KB_78688_remove-addon.sh

    iii. Execute the script by running this command:

    ./KB_78688_remove-addon.sh
     
  6. If you are using UMDS, export the UMDS content by running this command on the UMDS system:

    ./vmware-umds -E --export-store <repository_path>
     
  7. Re-sync the content download into vSphere Lifecycle Manager by selecting Home > Lifecycle Manager > Actions > Sync updates from the vSphere Web Client.


Attachments

KB_78688_remove-umds-addon get_app
KB_78688_remove-addon get_app