Usage Meter doesn't detect vSAN
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Usage Meter doesn't detect vSAN

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Article ID: 326909

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Updated On:

Products

VMware Aria Suite VMware vSAN

Issue/Introduction

Symptoms:
vSAN is not detected as enabled and its usage is not included in the VMware vCloud Usage Meter monthly report.

Environment

VMware vCloud Usage Meter 3.6.x

Cause

The cause of this issue is the difference in cluster name in the vCenter Inventory and the Licensing Service.
For example: In the vCenter Server inventory, the cluster name is "Your New Cluster" but in the Licensing Service the cluster name is "domain-c1". Usage Meter does not correctly recognize the vSAN enabled clusters. As a result, vSAN is not detected as enabled and Usage Meter does not collect any usage data. The vSAN usage is not included in the Monthly report.
This behavior is observed when vSAN is programmatically added in the vCenter Server inventory, where it is registered in the licensing service with the default name. This default name for the cluster is moref("domain-c1"). This behavior is unique to scripted vSAN enabled installations. For example: VxRAIL. 

Resolution

No resolution is available at this time. See the Workaround section.

Workaround:

To work around this issue, you need to rename the cluster, remove, re-add, and re-synchronize the vCenter Server to the Usage Meter inventory.
To apply the workaround:

  1. Login to the vSphere Web Client 
  2. Locate the affected vSAN cluster from the object inventory and rename it
  3. Log in to the Usage Meter web-portal 
  4. Delete the vCenter Server which is managing the renamed cluster
  5. Tick the "Show Inactive" box beside the vCenter product list
  6. Activate the vCenter Server again
  7. Synchronize the vCenter Server inventory
  8. Trigger a data collection
  9. Generate a Cluster History report 
  10. Confirm that vSAN cluster information is now recorded
Result: The vSAN is listed in the Monthly Report, as well as the Cluster Report.