Upgrade to vRealize Operations Manager 8.x fails due to the admin or root account password
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Upgrade to vRealize Operations Manager 8.x fails due to the admin or root account password

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Article ID: 315963

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
You may experience all, or some of these symptoms.
  • The upgrade to vRealize Operations Manager 8.x fails with the error:
Cannot continue the installation of the PAK file because Pre-Upgrade Validation Checks have failed.
  • The password for the admin account is locked or expired.
  • The vRealize Operations Manager node was deployed by the OVFTOOL and the root password was generated by the OVFTOOL.


Environment

VMware vRealize Operations 8.x

Cause

This issue can be caused by a locked or expired admin password or by an auto-generated root password.

Resolution

To resolve this issue, update the admin and/or root account passwords and run the upgrade again.
These steps can also be used before the upgrade to avoid possible issues.

To start, log into all of the vRealize Operations Manager nodes as root via SSH or Console.
Complete each section below.

Set Passwords to Not Expire

  1. Run the following commands to disable the password expiration for the admin, root, and postgres users.
chage -m 0 -M 99999 -I -1 -E -1 admin
chage -m 0 -M 99999 -I -1 -E -1 root
chage -m 0 -M 99999 -I -1 -E -1 postgres
  1. Repeat step 1 on all nodes in the vRealize Operations Manager cluster.
 

Reset the Passwords

 
  1. To reset the root password see How to reset the root password in vRealize Operations .
  2. Log into the master node as root and run the following command to reset the admin password:
$VMWARE_PYTHON_BIN $VCOPS_BASE/../vmware-vcopssuite/utilities/sliceConfiguration/bin/vcopsSetAdminPassword.py --reset

Note: Follow the prompts to enter a new admin password.
 
  1. Repeat step 1 on all nodes in the vRealize Operations Manager cluster.
 

Unlock the Accounts

  1. Run the following commands to ensure the admin and root accounts are not locked.

pam_tally2 --user admin --reset
pam_tally2 --user root --reset


Note: Re-run the commands until you receive output stating 0 failures
 

  1. Repeat step 1 on all nodes in the vRealize Operations Manager cluster.

 

Reset Failed Attempts

Follow the steps below to reset failed attempts for the application portion of the admin user.

  1. Open /storage/vcops/user/conf/adminuser.properties with a text editor.
  2. Delete the line that starts with failed_attempts=.
  3. Save and close the file.
  4. Repeat steps 1-4 on all nodes in the vRealize Operations Manager cluster.