"vCenter task and event collection failed for the following hosts" system alert received in vRealize Log insight
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"vCenter task and event collection failed for the following hosts" system alert received in vRealize Log insight

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Article ID: 330820

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • vRealize Log Insights receives a daily system alert stating: vCenter task and event collection failed for the following hosts
  • You see a similar message in /storage/core/loginsight/var/plugins/vsphere/li-vsphere.log stating:
[2019-05-21 14:11:15.988+0000] ["ScheduledPluginServiceScheduledTask-thread-1"/10.221.2.172 ERROR] [com.vmware.loginsight.vsphere.events.VimEventMonitor] [[https://vCenterFQDN/sdk] Failed to delete /storage/core/loginsight/var/plugins/vsphere/vCenterFQDN]


Cause

Files named after the vCenter FQDN in the /storage/core/loginsight/var/plugins/vsphere directory maintain information about the vCenters that are being monitored by the vSphere integration.
The timestamp details when the latest event was collected from the vCenter.

Sometimes, after an upgrade, vRealize Log Insight is unable to properly update the pre-existing vCenter files from the /storage/core/loginsight/var/plugins/vsphere directory, which will result in missed collections.

Resolution

To resolve this issue, manually delete the vCenter associated files for collections to resume.  To do so, complete the following steps on each node in the vRealize Log Insight cluster.
  1. Log into the vRealize Log Insight node as root via SSH or Console.
  2. Navigate to the /storage/core/loginsight/var/plugins/vsphere/ directory.
  3. Manually delete all files referring to the vCenter name listed in the system alert.
  4. Restart the Log Insight service:
service loginsight restart
  1. Repeat steps 1-4 on all vRealize Log Insight nodes in the cluster.
A new file will be generated for the vCenter and vRealize Log Insight will continue with the collection of vCenter events and tasks.