Export of vSphere ESX Agent Manager fails due to JVM heap exhaustion
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Export of vSphere ESX Agent Manager fails due to JVM heap exhaustion

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Article ID: 320894

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
After experiencing the symptoms seen in KB Article "Internal error occurs during Export of vSphere ESX Agent Manager" error when migrating vCenter Server 6.0 to 6.5 (2147898), you see these additional symptoms:
  • In the Export_com.vmware.eam.log file, you see these entries similar to: 

    2016-11-16T14:49:47.786Z WARNING eam vmware-eam service is not fully started, waiting till get up and running. Sleeping for 5 seconds. Error: HTTP Error 503: Service Unavailable (Failed to connect to endpoint: [class Vmacore::Http::LocalServiceSpec:0000000001F40F00] _serverNamespace = /eam _isRedirect = false _port = 15005)
    2016-11-16T14:49:52.786Z ERROR __main__ Upgrade Phase 'eam:Export' failed. Exception: expected string or buffer


    Note: The Export_com.vmware.eam.log file is found in the VMware-VCS-logs-<year><month><day><hour><minute><second>/vcsUpgrade folder.
     
  • In the eam.log file, you see entries similar to:

    2016-11-14T02:29:10.868-05:00 | INFO | eam-0 | VcConnection.java | 167 | Connecting to vCenter as com.vmware.vim.eam extension
    2016-11-14T02:29:10.881-05:00 | INFO | eam-0 | VcConnection.java | 603 | Connecting to https://VC_HOSTNAME:8089/sdk/vimService via vCenter proxy http://localhost:80
    2016-11-14T02:29:15.900-05:00 | ERROR | eam-0 | VcConnection.java | 179 | Failed to login to vCenter as extension. vCenter has probably not loaded the EAM extension.xml yet.: Cannot complete login due to an incorrect user name or password.
    2016-11-14T02:29:15.900-05:00 | WARN | eam-0 | VcListener.java | 114 | Trying to recover from error

     
  • In the wrapper.log file, you see entries similar to:

    INFO | jvm 2 | 2016/11/16 04:24:12 | java.lang.OutOfMemoryError: Java heap space
Notes
  • The eam.log and wrapper.log files are found in the VMware-VCS-logs-<year><month><day><hour><minute><second>/vcs_logs/eam folder.
  • The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Cause

This issue occurs due to a Java Virtual Machine (JVM) heap exhaustion.

Resolution

This issue is resolved in VMware vCenter Server 6.5 b, available at VMware Downloads .

Workaround:
To work around this issue if you do not want to upgrade, start the VMware ESX Agent Manager (EsxAgentManager) service on the Windows vCenter Server 6.0 and run the migration again. For more information on restarting services, see Stopping, starting, or restarting VMware vCenter Server 6.x services (2109881) .