Reset ESXi Root Password with Host Profile
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Reset ESXi Root Password with Host Profile

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Article ID: 323617

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Provide steps to reset host root password. No reboot necessary.

Symptoms:
ESXi host root password fails to authenticate forgotten and cannot authenticate into CLI

Environment

VMware vSphere ESXi 6.7
VMware vSphere ESXi 8.0
VMware vSphere ESXi 7.0
VMware vSphere ESXi 6.5

Cause

Misplaced or forgotten password.

Resolution

NOTE: Host profiles are a feature available on VMware vSphere Enterprise Plus license only. For more information refer to vSphere Host Profiles
Any other method is unsupported and reinstalling the ESXi host is the only supported way to reset a password on ESXi.Please note this kb does not apply for an ESXI 6.0 which is managed by a vCenter 6.5/6.7

1. Login to the vCenter WebClient
2. Go to Home and then choose Host Profiles from Operations and Policies Section.
3. Choose > Extract profile from a host.
4. In the Extract Host Profile menu wizard > Select the host you want to update the password for.
5. Name the Host Profile and click Next and then Finish to complete the capture of the host profile template.
 - The new host profile should appear on the Host Profile Objects Field.

6. Right Click the new Host Profile or using the Actions menu choose > Edit Settings
7. In the 'Edit Host Profile' Wizard. Uncheck all boxes.
8. Then using the search filter search for > root
9. Highlight and then select the check box for > root
10. A configurable window will display the root User configuration.
11. At the Password subsection, choose > Fixed password configuration
12. Here you will fill in the new password and confirm it before proceeding.
13. Double check that all other non applicable boxes have no check marks and proceed to Finish .
14. Once the Task Completes highlight the new host profile and from the 'Actions' drop down menu choose > Attach Detach Hosts and Clusters > then Select the host in the wizard.
15. From the Action Menu select Check Host Compliance.
16.  From the Action Menu select Remediate
17. Then Check Host Compliance.
18. Remove the Host Profile from the Host.

- At this time the host password should be successfully upgraded.


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Additional Information

VMware Skyline Health Diagnostics for vSphere - FAQ