[vRNI] [3.x] vRealize Network Insight UI not accessible from chrome version 71
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[vRNI] [3.x] vRealize Network Insight UI not accessible from chrome version 71

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Article ID: 314396

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Updated On:

Products

VMware Aria Operations for Networks

Issue/Introduction

This article provides information on how to fix an issue that prevents from logging in VMware vRealize Network Insight (vRNI)


Symptoms:
  • When using Chrome version 71 to browse vRealize Network Insight UI, you have an invalid redirection stating the current browser is not supported
  • Impacted vRNI version are 3.7,3.8 and 3.9.


Environment

VMware vRealize Network Insight 3.x

Cause

The new version of Google Chrome 71 was released on the 4th of December 2018. Customers who upgraded Google Chrome to latest version are affected with this issue.

Resolution

  • This issue will be fixed in upcoming releases of vRealize network insight
  • A patch is available for download and to fix the issue
Download Links:
For 3.9 setup : patch 
For 3.8 setup : patch
For 3.7 setup : patch


To apply the patch:

Note:
  • Apply this patch on all Platform(s) running vRealize Network Insight 3.7, 3.8 and 3.9. 
  • Patch is not required on Collector(s)

Log in to vRealize Network Insight Platform CLI using consoleuser and run these commands on all platform nodes (Default consoleuser password is: ark1nc0ns0l3 )

To upload the bundle via SCP (from remote host where you copied the file):
tool-manager copy scp --host ip_of_server_where_the_file_is_located --user user_to_access_server --path path_to_file_on_the_server/vRealizeNetworkInsight-Chrome71Support-201812051800.bundle

To upload the bundle via SCP (no remote host):

    Use WinSCP to copy bundle to the VRNI platform.
  • Start WinSCP
  • Change protocol to SCP
  • Connect to platform with support / ark1nc0113ct0r credentials (this is default password, the password in your environment may be different if you changed it)
  • Copy patch to /home/support directory
  • SSH to VRNI Platform as consoleuser and run the below command:
tool-manager copy scp --host localhost --user support --path /home/support/vRealizeNetworkInsight-Chrome71Support-201812201800.bundle

To upload the bundle via URL: 

tool-manager copy url https://s3-us-west-2.amazonaws.com/vrni-tools-archive/vRealizeNetworkInsight-Chrome71Support-201812201800/vRealizeNetworkInsight-Chrome71Support-201812201800.bundle

After the upload, apply the patch with:
tool-manager run --name vRealizeNetworkInsight-Chrome71Support-
201812201800.bundle

You see output similar to:

Verifying and unpacking bundle
Unpacked bundle
Verified tool compliant

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Run: vRealizeNetworkInsight-Chrome71Support-
201812201800.bundle
+ Description:To fix vRNI UI loading issue with Chrome 71
Execution time : 1 minute
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Go ahead with run? (y/n) [Default y]: y
Running...
Tool run completed


To verify the patch installation, run below command
(cli) show-version
3.9.0.1543904878
Chome71Support-
201812201800


Refer CLI guide for more information on tool-manager command: https://docs.vmware.com/en/VMware-vRealize-Network-Insight/3.8/com.vmware.vrni.cli.doc/GUID-7C990B0F-93A1-4870-92D9-32FDBC5BC876.html


Workaround:
Kindly use Mozilla Firefox or older version of Google Chrome (Version below 71).

Additional Information

  • md5sum: 7FEDDD2CCA380D7BA2284370677CD9DA
  • sha1sum: 441F3B64BF036E7ABFB8E678308C3237804C8C45
  • sha256sum: 2A4891ABEB64F9190C2D9EB2A671EF16FA4954C0063BA14243FE1A0E7BD4708E