vSAN Health Service - Online Health - vSAN Support Insight
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vSAN Health Service - Online Health - vSAN Support Insight

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Article ID: 327053

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Updated On:

Products

VMware vCenter Server VMware vSAN

Issue/Introduction

Symptoms:
vSAN health check warning when vSAN Support Insight is not enabled for the current environment.

Environment

VMware vSAN 6.7.x
VMware vCenter Server 7.0.x
VMware vSAN 8.0.x
VMware vSAN 7.0.x
VMware vCenter Server 6.7.x
VMware vCenter Server 8.0.x

Cause

This health check produces a warning when vSAN Support Insight is not enabled for the current environment. vSAN Support Insight is a next-generation platform for analytics of health, configuration, and performance telemetry. Its purpose is to help vSAN users maintain a reliable and consistent computing, storage and network environment.

vSAN Support Insight leverages the existing vCenter Customer Experience Improvement Program (CEIP) to collect health, performance, and configuration information for the VMware Support and engineering teams. After enabling and verifying, information is pushed back to the VMware’s Analytics Cloud on a regular cadence. Actual customer private data, user enterable or identifiable data (Hostnames, VM names, subnets, IP addresses, Mac addresses) are obfuscated or removed prior to pushing. For more information about privacy and how to inspect the phone home data see the following Cloud Platform Tech Zone article.

Resolution

To resolve the health check warning:
  1. Enable vSAN Support Insight by joining CEIP (Customer Experience Improvement Program).
  2. Ensure vCenter can reach the Internet, specifically, https://vcsa.vmware.com:443
Enable vSAN Support Insight
  1. In the health check, click on "Configure Support Insight" link.
  2. In the Customer Experience Improvement Program configuration screen, click on the "Join" button. 

Note: vSAN periodically retests each health check and updates the results so the alert may not clear immediately. To update the results immediately, click the Retest button.

Finer grain proxy configuration

If the system uses a firewall or a proxy to connect to the internet, then a firewall/proxy rule allowing outbound traffic is required for the proxy's allowlist to these destinations:

  1. https://vcsa.vmware.com:443/ph/api/*
  2. http://www.vmware.com:80

Note: This fine grain setting applies only for the vSAN Support Insight service. If there are other services requiring access to other destinations on the Internet, consult those services' documentation for their specific requirements.

Silence Alert

If the health check is not applicable to the current environment, you can disregard the health check (not recommended) by setting its alert level to "silent". Health check can be set to silent by one of the following methods:

  1. Use the Silence Alert button in the health check UI (next to the "Configure Support Insight" link).
  2. Use rvc command. For more information, see Silencing a vSAN  health check.