vSphere Client (HTML5) service fails to start
search cancel

vSphere Client (HTML5) service fails to start

book

Article ID: 318171

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • Accessing the vSphere Client (HTML5) of vCenter server in browser is failed with error message:
503 Service Unavailable (Failed to connect to endpoint: [class Vmacore::Http::LocalServiceSpec:0x000000cd9a3f7d70] _serverNamespace = /ui action = Allow _port=5090)
  • Services status in vCenter server with command "service-control --status --all" shows the "vsphere-ui" service in STOPPED status. 
  • Manually starting the service vsphere-ui but fails after ~15 minutes. 
  • n the vsphere_client_virgo.log file, you see entries similar to:
[2018-10-19T11:28:47.554+08:00] [ERROR] plugin-deploy2                com.vmware.vise.extensionfw.impl.PackagesDeployer                 Error deploying one of more bundles for the plugin package C:\ProgramData\VMware\vCenterServer\runtime\vsphere-ui\plugin-packages\license-client java.lang.Exception: Timed out waiting for a bundle to start.
        at com.vmware.vise.extensionfw.impl.DirectApiBundleDeployer.waitForBundlesStart(DirectApiBundleDeployer.java:98)
        at com.vmware.vise.extensionfw.impl.DirectApiBundleDeployer.deploy(DirectApiBundleDeployer.java:58)
[2018-10-19T11:28:47.557+08:00] [ERROR] plugin-deploy2                org.eclipse.virgo.medic.eventlog.default                         XF1009E Failed to deploy plugin package 'com.vmware.license.client' version '6.5.0.10000'.
[2018-10-19T11:38:48.014+08:00] [ERROR] ng DM Context Creation Timer  org.eclipse.virgo.medic.eventlog.default                         AG0000E Application context creation failure for bundle 'com.vmware.license.client-6.5.0.10000-com.vmware.license.client.licenseservice' version '6.5.0.13000'. org.springframework.context.ApplicationContextException: Application context initialization for 'com.vmware.license.client-6.5.0.10000-com.vmware.license.client.licenseservice' has timed out waiting for (objectClass=org.springframework.beans.factory.config.Scope)


Note: The location of vSphere Client (HTML5) log file is in the location:
  • VCSA: /var/log/vmware/vsphere-ui/logs
  • VC for Windows: C:\ProgramData\VMware\vCenterServer\logs\vsphere-ui\logs


Environment

VMware vCenter Server 6.5.x

Cause

The deployment method of DirectApiBundleDeployer causes caching issue with rpm installation which may make plugins deployment failed when vsphere-ui service started. In this sample the Client can not start in 15 minutes, but normally it should take no more than 5 minutes that was caused by failure of plugin deployment.

Resolution

This issue is resolved in vCenter Server 6.7, available at VMware Downloads.
 


Workaround:
To workaround this issue:
  1. Ensure the vsphere-ui service is in stopped status by running this command:
# service-control --status --all
 
  1. Delete or rename the HTML5 client work folder.
VCSA: /usr/lib/vmware-vsphere-ui/server/work
VC for Windows: C:\ProgramData\VMware\vCenterServer\runtime\vsphere-ui\server\work
       
Note:  Ensure backup of the folder is available
 
  1. Start the vsphere-ui service by running this command:
# service-control --start vsphere-ui
 
If the issue persist, perform the below steps:
  1. Ensure that the vsphere-ui service stopped.
  2. Delete the HTML5 client work folder.
  3. Open webclient.properties file that is located
  • VCSA: /etc/vmware/vsphere-ui
  • VC for Windows: C:\ProgramData\VMware\vCenterServer\cfg\vsphere-ui
  1. Add (or Edit) the following property
pickup.deployer=true
  1. Start the vsphere-ui service.