vCenter frequently reports errors on ESXi hosts "Device 10fb does not support flow control autoneg"
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vCenter frequently reports errors on ESXi hosts "Device 10fb does not support flow control autoneg"

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Article ID: 317587

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • vCenter is frequently reporting events from multiple hosts " Device 10fb does not support flow control autoneg "
  • ESXi hosts have Intel NIC cards using ixgben native driver.


Cause

This usually happens when link status changes or a user world application or external tool calls an internal VMKernel API prompting the  ixgben driver to query the device  for flow control autonegotation capability.
The log message means that the device hardware does not support flow control autoneg (Flow Control on this device, e.g. Intel X520, is a fixed one that cannot be modified).
 

Resolution

This issue is resolved in the "inbox" driver  in ESXi 6.7 Update 1  available at VMware downloads.

To resolve this issue, update the HPE Intel ixgben driver version to 1.7.10, available at the following URLs:

VMware ESXi 6.5 ixgben 1.7.10 NIC Driver for Intel Ethernet Controllers 82599, x520, x540, x550 and x552 family Version 1.7.10

Note: The ESXi 6.0 driver package is also compatible with ESXi 6.5

https://customerconnect.vmware.com/web/vmware/details?downloadGroup=DT-ESXI60-INTEL-IXGBEN-1710&productId=491 Non-HPE site

VMware ESXi 6.7 ixgben 1.7.10 NIC Driver for Intel Ethernet Controllers 82599, x520, x540, x550, x552 and x553 family Version 1.7.10

https://customerconnect.vmware.com/web/vmware/details?downloadGroup=DT-ESXI67-INTEL-IXGBEN-1710&productId=742 Non-HPE site Non-HPE site

Note: One or more of the links above will take you outside the Hewlett Packard Enterprise web site. HPE does not control and is not responsible for information outside of the HPE web site.


Workaround:
To workaround, this issue configure the monitoring tool to not query for the Flow Control Autonegotiation feature.

For "async" driver versions there is no fix available currently.  You can switch to the "inbox" driver version as a work-around. This is only available if you are using vSphere 6.7. Please contact VMware Support if you would like to pursue this work-around.