Error: "Failed to sync data on replica devices" while running Reprotect or Recovery on PURE storage reports
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Error: "Failed to sync data on replica devices" while running Reprotect or Recovery on PURE storage reports

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Article ID: 313923

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:
  • Running Reprotect or Recovery on SRM with PURE storage might report the error:
Error - Failed to sync data on replica devices. A storage operation requested on unknown storage device 'peer-xxxxxxxxxxxxx:LUN_NAME
  • However, re-running Reprotect or Recovery removes the error message.


Cause

Since SRM does not wait for storage side device discovery to complete before it triggers sync request during Reprotect operation, this process can result in a harmless/cosmetic error message caused by a delay in device discovery process.

Resolution


This error message can be safely ignored.
This has no impact to the SRM, SRA or Storage Array functionality. In addition, SRM's Reprotect and Failover functionalities are NOT impacted.

Additional Information

Impact/Risks:

This is cosmetic UI reported issue and has no impact on the Reprotect and subsequent Failover operations.