Logging into the vSphere Web Client hangs after VC 6.7 upgrade
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Logging into the vSphere Web Client hangs after VC 6.7 upgrade

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Article ID: 318176

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

This article provides information on restoring vSphere Web Client (Flash) 6.7 operations after login with installed plug-ins.

Symptoms:
  • After upgrading to vCenter Server 6.7, logging into the vSphere Web Client hangs.
  • In the vsphere_client_virgo.log file, you see entries similar to:
[2018-04-23T15:06:03.415+10:00] [ERROR] http-nio-9090-exec-1 70000020 ###### ###### Endpoint.AMF null java.lang.NullPointerException: null
[2018-04-24T19:59:10.152+03:00] [ERROR] start-signalling-3 org.springframework.flex.core.MessageBrokerFactoryBean Error thrown during MessageBroker initialization org.springframework.aop.framework.AopConfigException: Unexpected AOP exception; nested exception is java.lang.RuntimeException: java.lang.ClassNotFoundException: org.springframework.cglib.proxy.NoOp not found from bundle [com.<Offending Plugin>]


Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

The vsphere_client_virgo.log file is located at:
  • vCenter Server on Windows - C:\ProgramData\VMware\vCenterServer\logs\vsphere-client\logs\
  • vCenter Server Appliance - /var/log/vmware/vsphere-client/logs


Environment

VMware vCenter Server 6.7.x

Cause

This issue occurs when the new version of the application server responsible for rendering the plug-ins in the vSphere Web Client (Flash) 6.7 is missing the libraries needed by the plug-ins. This disrupts the communication path between the browser and the application server of the vSphere Web Client.

Resolution

This issue is resolved in vCenter Server 6.7.0a,  available at VMware Downloads

Workaround:
To work around this issue, run the following script on the vCenter Server 6.7.
Scripts (whitelist-plugins.sh & whitelist-plugins.bat) can be downloaded from the KB Attachements.

The script contains commands to:

Whitelist the following verified plug-ins:
  • VMware Update Manager
  • VMware Virtual SAN
  • VMware Site Recovery Manager 8.0
  • VMware vSphere Replication 8.0
  • Dell EMC's OpenManage 4.2 Integration for VMware vCenter
  • Nimble Storage 5.0

Applying the Whitelist script:

The steps on applying the Whitelist script are listed below:

In Windows-based vCenter Server

  1. Download whitelist-plugins.bat from this KB attachments and copy the file to a directory on the vCenter Server.
  2. Open the command prompt (as Administrator) to run the script.
  3. To apply the whitelist script for your vCenter Server, run this command:

    <path_to_script>\whitelist-plugins.bat apply

In vCenter Server Appliance

  1. Log into the bash shell as root. For more information, see the Enable and Access the Bash Shell from the Appliance Shell section of the vCenter Server Appliance Configuration Guide.
  2. To upload the files to VCSA run the below command to change the default shell to bash which enables you to copy the files using WinSCP. For more information refer KB article.
    • chsh -s /bin/bash root
  3. Using WinSCP, Download whitelist-plugins.sh from the KB attachments and copy the attached whitelist-plugins.sh to the /tmp/ directory.
  4. Run this command:

    chmod +x /tmp/whitelist-plugins.sh
     
  5. To apply the whitelist script for your vCenter Server appliance, run this command:

    sh /tmp/whitelist-plugins.sh apply
Notes:
  • Be sure to refresh the browser after applying the script.
  • After applying the script, you should be able to log in to the vSphere Web Client (Flash). To see the results of the whitelist action after logging in, navigate to the Administration section and click Client Plug-Ins. Installed plug-ins included in the whitelist will display as “Enabled”, while plug-ins not included in the whitelist script will be displayed as “Incompatible.”

Revert the plug-in whitelist configuration:

This option allows you to restore pre-whitelist configuration after upgrading plug-ins to a vSphere 6.7-compatible version.

In Windows-based vCenter Server

  1. Download whitelist-plugins.bat file from the KB attachments and copy the to a directory on the vCenter Server. (If not already done so).
  2. Open the command prompt (as Administrator) to run the script.
  3. To revert the changes, run this command:

    <path_to_script>\whitelist-plugins.bat revert

In vCenter Server Appliance

  1. Log into the bash shell as root. For more information, see the Enable and Access the Bash Shell from the Appliance Shell section of the vCenter Server Appliance Configuration Guide.
  2. Using WinSCP, Download whitelist-plugins.sh from the KB attachments and copy the attached whitelist-plugins.sh to the /tmp/ directory. (if not already done so).
  3. Run this command:

    chmod +x /tmp/whitelist-plugins.sh
     
  4. To revert the changes, run this command:

    sh /tmp/whitelist-plugins.sh revert
Note: Be sure to refresh the browser after applying the script.

Additional Information

VMware is enabling special engagements for partners to update their plug-ins and certify to ensure compatibility with vSphere 6.7. For more information on the list of partner certified plugins, see the VMware Compatibility Guide.

Impact/Risks:
Upon logging in with the vSphere Web Client (Flash) where certain incompatible plug-ins had been installed, a user finds that the client hangs. The vSphere client (HTML5) and its plug-ins are not affected by this issue.

Attachments

whitelist-plugins.bat get_app
whitelist-plugins.sh get_app