Windows 7 and 2008 virtual machines lose network connectivity on VMware Tools 10.2.0
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Windows 7 and 2008 virtual machines lose network connectivity on VMware Tools 10.2.0

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Article ID: 318784

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • The virtual machines are Windows 7 or Windows Server 2008.
  • The virtual machines are using VMware Tools 10.2.0.
  • The virtual machines lose connectivity due to port exhaustion.
  • Virtual machine may respond to pings.


Environment

VMware vSphere ESXi 6.5
VMware vSphere ESXi 6.7
VMware vSphere ESXi 6.0
VMware vSphere ESXi 5.5

Cause

This issue is is caused by a resource leak in the Common Agent Framework (CAF) provided in VMware Tools 10.2.0. CAF provides the basic services necessary to simplify secure and efficient management of agents inside the guest virtual machines.

This issue will be seen as unclosed socket connections causing port exhaustion. RDP to the machine will not work and any email clients also will not make any outbound connections, while ping may work. The issue might occur every 1 to 4 days.

Resolution

To resolve this issue upgrade to VMware Tools 10.2.5, available at VMware Downloads.

Workaround:
To workaround this issue set the CAF service to manual:
  1. Open an elevated command prompt in the affected virtual machine.
  2. Run these commands:
sc stop VMwareCAFManagementAgentHost
sc config VMwareCAFManagementAgentHost start= demand