/storage/log is full on vRealize Operations
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/storage/log is full on vRealize Operations

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Article ID: 318019

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • The /storage/log partition is full on one or more vRealize Operations node and these log files are consuming this space:
    • /var/log/auth.log
    • /var/log/messages
    • /var/log/warn


Environment

VMware vRealize Operations 8.x
VMware vRealize Operations Manager 7.5.x
VMware vRealize Operations 8.0.x
VMware vRealize Operations 8.1.x
VMware vRealize Operations Manager 7.0.x

Cause

In vRealize Operations 8.x this is caused by the move to Photon OS and an incorrect log rotation mechanism.

Resolution

To resolve this issue remove the /var/log/warn/var/log/auth.log, and /var/log/messages files.
  1. Log into the vRealize Operations node as root via SSH or Console, pressing ALT+F1 in a Console to log in.
  2. Run the following command to stop the syslog service:
service syslog stop
  1. Remove the /var/log/warn/var/log/auth.log, and /var/log/messages files by running this command:
rm -f /var/log/warn* /var/log/auth.log* /var/log/messages*
  1. Run the following command to start the syslog service:
service syslog start
  1. Repeat steps 1-4 on any other affected nodes.
Note: If this article does not resolve your issue, see Troubleshooting Storage Issues in vRealize Operations (83239).

Additional Information

Impact/Risks:
Logs only fill the /storage/log partition. Removing log data will not reduce space in the other partitions.

It is recommended to take a snapshot following How to take a Snapshot of vRealize Operations (2149269) before proceeding with the steps below.