VMware vCenter Server のリソース使用率が 100% に達し、応答しなくなる
search cancel

VMware vCenter Server のリソース使用率が 100% に達し、応答しなくなる

book

Article ID: 342331

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

免責事項: これは英文の記事 「VMware vCenter Server resource usage is 100% and becomes unresponsive (2034127)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。


  • vpxd.exe プロセスは CPU リソースを 100% 消費します。
  • vpxd.exe は大量の物理メモリを消費します。
  • VMware vCenter Server にログインすることはできません。
  • クラスタ ビューのパフォーマンス チャートに次のメッセージが表示されます:

    データ ソースがタイムアウトになりました

  • 次のエラーが表示されます。

    リモート サーバの応答時間が長すぎたため、要求に失敗しました

  • vpxd.log ファイルには、秒ごとの vCenter PerformanceManager API の呼び出しが次のように複数回表示されます。

    [2012-07-17 09:47:24.861 13880 info 'App' opID=51d096b0] [VpxLRO] -- BEGIN task-internal-19566612 --
    -- vim.PerformanceManager.queryStats -- A5113EB8-C947-4D5D-A477-B9CFB084AD19(374B3D36-B796-45FB-
    27-5A6464630DDD)


Environment

VMware vCenter Server 4.1.x
VMware vCenter Server 4.0.x
VMware vCenter Server 5.1.x
VMware vCenter Server 5.0.x

Cause

PerformanceManager API を何度も呼び出すと、vpxd.exe は大量のリソースを消費します。これらの呼び出しは、実行中に統計情報を生成し、計算の負荷が大きいため、大量のリソースを消費します。

サードパーティの監視製品には、この API に対する呼び出しを大量に生成するものがあり、リソースのロードは許容できないレベルに達します。

Resolution

vpxd.log ファイルに表示されるセッション ID(これらの例では A5113EB8-C947-4D5D-A477-B9CFB084AD19)を使用して vpxd-profiler.log ファイルを検索し、問題のあるユーザーまたはサービス アカウント名、および送信元の IP アドレスを特定することができます。

この問題を解決するには:
  1. vpxd-profiler.log ファイルでセッション ID を検索します。これは、PerformanceManager インターフェイス上でリソース負荷を引き起こしているセッションの発生元についての追加情報を提供します。

    例:

    B9CFB084AD19'/Username='DOMAIN\TivoliVI'/ClientIP='10.0.0.1'/PropertyCollector/NullCollectorCount/total 0
    /SessionStats/SessionPool/Session/Id='A5113EB8-C947-4D5D-A477-B9CFB084AD19'/Username='DOMAIN\TivoliVI'/ClientIP='10.0.0.1'/PropertyCollector/QueuedOpsCount/total 0
    /SessionStats/SessionPool/Session/Id='A5113EB8-C947-4D5D-A477-B9CFB084AD19'/Username='DOMAIN\TivoliVI'/ClientIP='10.0.0.1'/PropertyCollector/ReadLocked/total 0
    /SessionStats/SessionPool/Session/Id='A5113EB8-C947-4D5D-A477-B9CFB084AD19'/Username='DOMAIN\TivoliVI'/ClientIP='10.0.0.1'/PropertyCollector/TotalObjectCount/total 3239
    /SessionStats/SessionPool/Session/Id='A5113EB8-C947-4D5D-A477-B9CFB084AD19'/Username='DOMAIN\TivoliVI'/ClientIP='10.0.0.1'/PropertyCollector/TriggeredFiltersCount/total 1
    /SessionStats/SessionPool/Session/Id='A5113EB8-C947-4D5D-A477-B9CFB084AD19'/Username='DOMAIN\TivoliVI'/ClientIP='10.0.0.1'/PropertyCollector/TriggeredProcessGUReqs/total 0
    /SessionStats/SessionPool/Session/Id='A5113EB8-C947-4D5D-A477-B9CFB084AD19'/Username='DOMAIN\TivoliVI'/ClientIP='10.0.0.1'/SoapSession/Id='11808511'/Count/total 1

    この例では、PerformanceManager API を呼び出すために使用されたアカウントは DOMAIN\TivoliVI で、IP が 10.0.0.1 のワークステーションで発生しました。

  2. vpx-profiler.log ファイルで、CPU 使用率追跡カウンタが 100% 実行していることを確認します。次のような、約 5 分おきに繰り返している行を見つけます:

    /ProcessStats/ProcessorCpuUsage/mean 100

    • vCenter 5.0 では、この値は 100 を掛けた割合として表現されます。したがって、100% は値 10000 として表現されます。
    • vCenter 4.1 以前では、この値は割合としてのみ表現されます。したがって、100% は値 100 として表現されます。

  3. ユーザーまたはサービス アカウント、および接続元を特定したら、アカウントまたはサービスを無効にして、vCenter Server に接続しないようにします。

  4. アカウントまたはサービスを無効にしたら、リソースの使用が許容可能なレベルに戻っていることを確認します。

  5. 問題がサードパーティ製品にある場合は、ベンダーに追加サポートを依頼してください。


Additional Information

この記事が更新されたときにアラートを表示するには、Actions ボックスで Subscribe to Article をクリックします。