Error: "vSphere HA agent cannot be correctly installed or configured"
search cancel

Error: "vSphere HA agent cannot be correctly installed or configured"

book

Article ID: 318929

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Provide information on how to troubleshoot and fix vSphere HA not configuring on ESXi hosts.

Symptoms:
  • Unable to install or update the vCenter Server vSphere High Availability (vSphere HA) agent service.
    • The vmware-fdm VIB is the package that runs this service on each ESXi host
  • Powering on virtual machines fails with error:
    The host is reporting errors in its attempts to provide vSphere HA support
  • In the VMware vCenter Server summary, you may see this vSphere HA service error:
    vSphere HA agent for this host has an error: vSphere HA agent cannot be correctly installed or configure


Environment

VMware vSphere ESXi 7.0.0
VMware vSphere ESXi 6.5
VMware vSphere ESXi 5.5
VMware vSphere ESXi 6.0
VMware vSphere ESXi 5.0
VMware vSphere ESXi 6.7
VMware vSphere ESXi 5.1

Cause

Some things which can cause this issue include:
  • ESXi host problem with third-party VIB
  • ESXi host heartbeat datastore problems
  • ESXi host OS problems
  • vCenter Server OS problems

Resolution

To resolve this issue: 
  1. If the error is "vSphere HA agent is unreachable" follow vSphere HA agent is unreachable and the Summary tab of the ESXi host reports the error: vSphere HA reports that an agent is in the Agent Unreachable state
  2. If the ESXi host is in a vSAN cluster, ensure:
    1. It is networked to, configured for, and participating in the vSAN cluster.
    2. It is showing good health for vSAN per Check vSAN Health.
  3. Disconnect, then reconnect the ESXi host to vCenter
    1. In the vCenter GUI, use the Hosts and Clusters view,
    2. Right-click the ESXi host and select Connection > Disconnect
    3. Right-click the ESXi host and select Connection > Connect
    4. Disable, then re-enable vSphere HA for the cluster per Configuring vSphere Availability Settings.
  4. If the problem persists, check whether the vSphere HA agent service needs restarting per Reconfiguring HA (FDM) on a cluster fails with the error: Operation timed out.
  5. If the problem persists, restart the vSphere HA service for the cluster
    1. Turn vSphere HA off for the whole cluster per Disabling VMware High Availability (HA).
    2. Turn vSphere HA back on for the whole cluster per Configure vCenter HA With the vSphere Client.
  6. If the problem persists, check whether the ESXi host version is compatible with the vCenter Server version per the VMware Product Interoperability Matrix.
    1. If not compatible, upgrade the software appropriately.
    2. If upgrading your ESXi hosts, always check the VMware Compatibility Guide to ensure the server hardware is compatible with the new ESXi version.
  7. If the problem persists, follow ESXi host not responding , /tmp folder 100% to check and resolve if the ramdisk /tmp directory is too full.
  8. If the problem persists, review the /var/run/log/fdm-installer.log file:
cat /var/run/log/fdm-installer.log |less
bootbank_qlogic_hcli_2.2.60.7.0.0vmw.500.0.0.472560 violates extensibility rule: Installing the VIB
fdm-installer: [24683] 2013-07-18 18:41:45: Result of esxcli software vib install -v=/tmp/vmware-root/ha-agentmgr/vpx-upgrade-installer/vmware-fdm.vib: [DependencyError]
fdm-installer: VIB QLogic_bootbank_qlogic_hcli_2.2.60.7.0.0vmw.500.0.0.472560 violates extensibility rule checks: [u'(line 31: col 0) Element vib failed to validate content']
fdm-installer
  1. If the problem persists, check for heartbeat datastore problems per Troubleshoot ESXi heartbeat datastore problems affect vSphere HA.
  2. If the problem persists, restart the Platform Services Controller (if your vCenter uses an external PSC). Once it finishes rebooting, then restart the vCenter Server managing the ESXi host.
    1. Note that versions 7.x have no external PSC, it is always embedded into vCenter
    2. If you're running a 6.x version and unsure if your vCenter uses an external PSC or which device the external PSC is, follow How to find your vCenter Server's PSC.
  3. If the problem persists, rule out network issues
    1. Ensure that if the ESXi host vmnics MTU size is set uniformly, across all switch ports and other infrastructure are allowing that MTU to go through. 
    2. Ensure that no firewall changes were made to the ESXi host or network switches blocking ports 80, 443, or 902 between hosts and vCenter Server.
  4. If the problem persists, restart management services on the ESXi host per Restarting the Management agents in ESXi.
  5. If the problem persists, follow the bottom half of the article Resolve third-party VIB preventing vSphere HA agent updates, starting at "To remove the vSphere HA agent VIB".
  6. If the problem persists, reboot the ESXi host.


Additional Information



Impact/Risks:
When ESXi host cannot install or configure to join the vSphere HA agent, VMs may not vMotion to it or may not restart on another ESXi host if the problem ESXi host fails.
Restarting management agents on ESXi hosts risks that the agents don't fully restart. In that situation you may find you have to shut down the running VMs on the host and reboot the host to recover.