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Article ID: 344652
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Updated On:
Environment
VMware vCenter Site Recovery Manager 6.0.x
VMware vCenter Site Recovery Manager 5.5.x
VMware vCenter Site Recovery Manager 8.x
VMware vCenter Site Recovery Manager 5.8.x
VMware vCenter Site Recovery Manager 5.1.x
Cause
This issue occurs when one or more virtual machines have a large number of snapshots. When gathering virtual machine data, the SRM service becomes corrupted when attempting to serialize the data.
Resolution
To resolve this issue, consolidate snapshots on virtual machines with a large number of snapshots, then start the SRM service.
For more information, see:
Note: The maximum supported number of snapshots in a chain is 32. For more information, see Best practices for virtual machine snapshots in the VMware environment (1025279).
To work around the issue if the snapshots are required for roll-back and cannot be removed, remove virtual machines with large numbers of snapshots from their protection group. This stops SRM from trying to gather information about the virtual machines and the service starts normally.
Additional Information
To identify the virtual machines that have snapshots, use one of these methods:
- In vSphere Client, click the Storage Views tab for each virtual machine.
- In an ESXi host, run this command:
find /vmfs/volumes -name \*delta\* -print
Notes:
- You may also experience a similar issue with a different error message:
site recovery manager server service terminated unexpectedly 7034.
- Use the same resolution of snapshot consolidation to resolve the issue.
Committing snapshots when there are no snapshot entries in the Snapshot ManagerCollecting diagnostic information for Site Recovery ManagerConfiguring vCenter Server to send alarms when virtual machines are running from snapshotsBest practices for using snapshots in the vSphere environmentHow to consolidate snapshots in vSphere 5.x/6.xSRM サービスが Windows イベント ビューアーのエラーで起動に失敗する