SRM service fails to start with an error in the Windows Event Viewer
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SRM service fails to start with an error in the Windows Event Viewer

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Article ID: 344652

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:
  • VMware vCenter Site Recovery Manager (SRM) fails to start.
  • The SRM service fails to start.
  • In the Windows Event Viewer, you see one of these errors:

    • Faulting application vmware-dr.exe, version 5.1.0.4866, time stamp 0x50c91bd1, faulting module ntdll.dll, version 6.0.6002.18541, time stamp 0x4ec3e855, exception code 0xc0000005, fault offset 0x000000000004bf71, process id 0x1ff4, application start time 0x01ce03b667383f67

      Faulting application name: vmware-dr.exe, version: 5.1.0.4866, time stamp: 0x50c91bd1 Faulting module name: ntdll.dll, version: 6.1.7601.17725, time stamp: 0x4ec4aa8e Exception code: 0xc0000005 Fault offset: 0x0000000000053560 Faulting process id: 0x1fbc Faulting application start time: 0x01ce0f5a7ca3f655 Faulting application path: C:\Program Files\VMware\VMware vCenter Site Recovery Manager\bin\vmware-dr.exe Faulting module path: C:\Windows\SYSTEM32\ntdll.dll Report Id: cce4ca8b-7b4d-11e2-952c-005056905535

    • Faulting application vmware-dr.exe, version 5.5.0.7830, time stamp 0x522dc458, faulting module ntdll.dll, version 6.0.6002.18327, time stamp 0x4cb74dd3, exception code 0xc0000005, fault offset 0x00000000000496d3, process id 0x6d8, application start time 0x01cee778b6289dd5.

  • SRM logs do not indicate that there is an issue. For more information, see Collecting diagnostic information for Site Recovery Manager (1009253).


Environment

VMware vCenter Site Recovery Manager 6.0.x
VMware vCenter Site Recovery Manager 5.5.x
VMware vCenter Site Recovery Manager 8.x
VMware vCenter Site Recovery Manager 5.8.x
VMware vCenter Site Recovery Manager 5.1.x

Cause

This issue occurs when one or more virtual machines have a large number of snapshots. When gathering virtual machine data, the SRM service becomes corrupted when attempting to serialize the data.

Resolution

To resolve this issue, consolidate snapshots on virtual machines with a large number of snapshots, then start the SRM service.
For more information, see:

Note: The maximum supported number of snapshots in a chain is 32. For more information, see Best practices for virtual machine snapshots in the VMware environment (1025279).

To work around the issue if the snapshots are required for roll-back and cannot be removed, remove virtual machines with large numbers of snapshots from their protection group. This stops SRM from trying to gather information about the virtual machines and the service starts normally.


Additional Information

To identify the virtual machines that have snapshots, use one of these methods:
  • In vSphere Client, click the Storage Views tab for each virtual machine.
  • In an ESXi host, run this command:

    find /vmfs/volumes -name \*delta\* -print
Notes:
  • You may also experience a similar issue with a different error message:

    site recovery manager server service terminated unexpectedly 7034.

  • Use the same resolution of snapshot consolidation to resolve the issue.
Committing snapshots when there are no snapshot entries in the Snapshot Manager
Collecting diagnostic information for Site Recovery Manager
Configuring vCenter Server to send alarms when virtual machines are running from snapshots
Best practices for using snapshots in the vSphere environment
How to consolidate snapshots in vSphere 5.x/6.x
SRM サービスが Windows イベント ビューアーのエラーで起動に失敗する