The vSphere Distributed Switch configuration on some hosts differed from that of VMware vCenter- "Out of Sync"
search cancel

The vSphere Distributed Switch configuration on some hosts differed from that of VMware vCenter- "Out of Sync"

book

Article ID: 317901

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • You see this banner alert in the Networking view:
The vSphere Distributed Switch configuration on some hosts differed from that of the vCenter Server.
  • When viewing a list of hosts attached to the distributed switch, or from the manage hosts wizard under the vDS Status column, you see a yellow warning icon and the message:
Out of sync


Cause

Although Distributed Switches are a component within vCenter Server, most of the switch's underlying functionality is handled at the ESX/ESXi host level. As such, relevant vDS configuration information is stored locally on the host as a proxy copy and are periodically synchronized with vCenter Server.


If network connectivity is interrupted between the vCenter Server and one or more hosts, a synchronization interval may be missed resulting in this alert being displayed. This type of interruption can occur during vCenter Service restarts, vCenter Server reboots as well as ESX/ESXi host reboots or network maintenance. This message can also occur if the host is taken out of a vCenter Server while still attached to a vDS, then brought in to a new vCenter Server. Even if the vDS on the new vCenter Server is the same or similar to the vDS on the previous vCenter, the new vCenter Server will not recognize the host's proxy copy of the vDS.

Resolution

Most of the time, this message is benign and can be safely ignored until a maintenance window. Within several minutes, the host's Distributed Switch information should synchronize with vCenter Server, and the warning may clear on its own.

Process to synchronize the host vDS information from the vSphere Client:

To manually synchronize the host vDS information from the vSphere Client follow the steps below:

  1. In the Inventory section, click Home > Networking.

  2. Select the vDS displaying the alert and then click the Hosts tab.

  3. Right-click the host displaying the Out of sync warning and then click Rectify vNetwork Distributed Switch Host.

Process to clear host's proxy copy from the host:

If the Rectify button does not clear the message or the button is not available on the host, the host's proxy copy must be cleared from the host. To do this, the host must be removed from the vDS entirely. After removal, it can then be brought back in to the vDS and the message will clear. This involves a networking change, so it is recommended to do this step during a maintenance window, if possible.

  1. Move all attached virtual machines to another host or to a standard switch.

    1. A new standard switch can be built using one of the physical adapters that passes the correct VLANs from the vDS. See the note below on Load Balancing information.

  2. Move all vmkernels from the vDS to a standard switch.

    1. Again, a new standard switch can be built using one of the physical adapters that passes the correct VLANs from the vDS. See the note below on Load Balancing information.

  3. Remove any remaining physical adapters from the vDS.

  4. Remove the host from the vDS. Click Home > Networking. Right click the vDS, click Add and Manage Hosts > Remove Hosts, and follow the wizard.
    NOTE: if there is an error about "Port-id is in use", follow this KB: The resource 'Port-ID' is in use error when removing a host from VDS

  5. Add the host back to the vDS along with its vmkernels, physical adapters, and VMs.

NOTE: if you need to use the same physical adapters from the current vDS on the standard switch, check the Load Balancing on the distributed switch. To do this, click Home > Networking, then click the vDS that is being cleared. Next, click the three dots next to the port group you are copying, then click View Settings > Policies and scroll down to Load Balancing. If the Load Balancing is set to IP Hash, this setting must be broken on the physical switch in order to use these physical adapters on the standard switch.


If vCenter Server or an ESX/ESXi host has not been restarted recently and the alert does not clear on its own, there may be other problems in the environment inhibiting the synchronization of vDS data. If the problem persists, Ensure there are no intermittent network connectivity issues with the ESX/ESXi host or to vCenter Server. For more information, see ESX/ESXi hosts have intermittent or no network connectivity (1004109).

Other related KBs:



Workaround:
See ESXi hosts showing out of sync with distributed switch (76959) for more potential work arounds on the Out of Sync issue.

Additional Information

To be alerted when this document is updated, click the Subscribe to Article link in the Actions box
For more information, see: 

For translation version of this article, see:

Impact/Risks:
Ensure that MTU settings on the VSS and vmkernel ports match the distributed switch. Failure to have consistent MTU settings will negatively impact traffic and may cause outages for some services. 

Do not migrate NSX vmkernel ports. Please follow appropriate NSX documentation for the correct process to migrate between distributed and standard switches.