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Article ID: 324556
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Issue/Introduction
To resolve the issue of significant packet loss during periods of very high traffic bursts:
- Ensure that there is no traffic filtering occurring (for example, with a mail filter).
- Check the driver/firmware of the ESXi's physical NICs and update if needed. To check the driver/firmware, see Determining Network/Storage firmware and driver version in ESXi.
- NOTE: if physical NIC errors are also incrementing, please investigate with physical NIC vendor. See Troubleshooting network receive traffic faults and other NIC errors in ESXi
- After eliminating the above possibilities, slowly increase the number of buffers in the guest operating system.
Symptoms:
When using the VMXNET3 driver on a virtual machine on ESXi, you see significant packet loss during periods of very high traffic bursts. The virtual machine may even freeze entirely. Doing one of the following may resolve the issue:
- vMotion the VM to another host
- disconnect and reconnect the VM's adapter
Environment
VMware vSphere ESXi 6.7
VMware vSphere ESXi 5.5
VMware vSphere ESXi 5.0
VMware vSphere ESXi 5.1
VMware ESXi 4.1.x Embedded
VMware ESXi 4.1.x Installable
VMware vSphere ESXi 7.0.0
VMware vSphere ESXi 6.0
VMware vSphere ESXi 6.5
Cause
This can occur due to a lack of receive and transmit buffer space or when receive traffic which is speed-constrained using, for example a traffic filter.