ESXi 5.0 host may fail with a purple diagnostic screen when using Hardware Acceleration (VAAI) XCOPY
search cancel

ESXi 5.0 host may fail with a purple diagnostic screen when using Hardware Acceleration (VAAI) XCOPY

book

Article ID: 305093

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
When using the hardware acceleration (VAAI) XCOPY SCSI command with a storage array that supports it, in some cases when the storage array returns a Check Condition with Sense/ASC/ASCQ indicating "Copy Aborted, Third Party Device Failure", you can experience these symptoms:

  • ESXi hosts fail with a purple diagnostic screen.
  • You see an error similar to:

    #PF Exception 14 in world 635691:vmm2:lon-pat IP 0x41803089eb0a addr 0x412400c87380
    2012-08-10T08:42:27.631Z cpu18:4114)0x412200487548:[0x41803749eb0a]SCSICloneBlocksDone@vmkernel#nover+0xbd stack: 0x41000d0fc990, 0x418
    2012-08-10T08:42:27.632Z cpu18:4114)0x412200487688:[0x41803749b744]SCSICompleteDeviceCommand@vmkernel#nover+0x1343 stack: 0x4122004876b
    2012-08-10T08:42:27.632Z cpu18:4114)0x4122004876b8:[0x418037753d60][email protected]#v2_0_0_0+0x133 stack:
    2012-08-10T08:42:27.632Z cpu18:4114)0x4122004877c8:[0x41803775414d][email protected]#v2_0_0_0+0x338 stack: 0
    2012-08-10T08:42:27.633Z cpu18:4114)0x412200487848:[0x4180374b0b8c]SCSICompletePathCommand@vmkernel#nover+0x37f stack: 0x4dc1eeee64f9bc
    2012-08-10T08:42:27.633Z cpu18:4114)0x4122004878c8:[0x4180374a2be9]SCSICompleteAdapterCommand@vmkernel#nover+0x250 stack: 0x41002547428
    2012-08-10T08:42:27.633Z cpu18:4114)0x412200487a28:[0x4180376d5c8f][email protected]#9.2+0x412 stack: 0x0, 0x410
    2012-08-10T08:42:27.634Z cpu18:4114)0x412200487ad8:[0x4180372ed51e]WorldletProcessQueue@vmkernel#nover+0x3c5 stack: 0x412200487b28, 0xa
    2012-08-10T08:42:27.634Z cpu18:4114)0x412200487b18:[0x4180372eda29]WorldletBHHandler@vmkernel#nover+0x60 stack: 0x412200487bb8, 0x41804
    2012-08-10T08:42:27.635Z cpu18:4114)0x412200487b78:[0x4180372182fc]BHCallHandlers@vmkernel#nover+0xbb stack: 0x22282500000073, 0x73, 0x
    2012-08-10T08:42:27.635Z cpu18:4114)0x412200487bb8:[0x4180372187eb]BH_Check@vmkernel#nover+0xde stack: 0x412200487d88, 0x412200487cc0,


  • Rebooting the ESXi host returns the system to normal operation.


Environment

VMware vSphere ESXi 5.0

Cause

This issue occurs when the buffer overflows. A buffer overflow occurs when a program or process tries to store more data in a buffer (temporary data storage area) than it was intended to hold. Since buffers are created to contain a finite amount of data the extra information, which has to go somewhere, can overflow into adjacent buffers, corrupting or overwriting the valid data held in them.

Resolution

This issue is resolved in ESXi 5.0 Update 2. For more information about this version, see the ESXi 5.0 Update 2 Release Notes. You can download the latest release from the VMware Download Center.
To work around this issue when you cannot upgrade, disable VAAI on your ESXi host. For more information, see Disabling the VAAI functionality in ESXi/ESX (1033665).


Additional Information

To be alerted when this document is updated, click the Subscribe to Article link in the Actions box
Disabling the VAAI functionality in ESXi/ESX