Cannot log in to vMA using the Web interface or SSH
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Cannot log in to vMA using the Web interface or SSH

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Article ID: 309737

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Cannot log in to vSphere Management Assistant (vMA) using the Web interface or Secure Shell (SSH).
  • Logging in to vMA using the Web interface or SSH fails.
  • When logging in to vMA via SSH, you see the error:

    Error: Access Denied

  • When logging in to vMA via Web interface, you see the error:

    Error: Unable to authenticate user. Please try again.

  • You are able to log in to vMA using the vMA console.


Environment

VMware vSphere Management Assistant 4.1
VMware vSphere Management Assistant 5.5

Cause

The issue occurs if there is a backslash (\) character in the vMA password.

Resolution

To resolve this issue, ensure the vMA password does not include a backslash character.

To change the vMA password ensuring there is no backslash character:
  1. Connect to the vMA console in a vSphere Client.
  2. Press Alt + F2 to access the login prompt.
  3. Enter vi-admin for the user and enter the current password.
  4. In the command-line, run the command:

    passwd

  5. When prompted, enter a new password that does not include a backslash.


Additional Information

For more information, see the vSphere Management Assistant Guide.

To troubleshoot SSH issues on the vMA:
  1. To determine if the sshd service is running, run the command:

    # sudo service sshd status

  2. If the SSH service is not running, restart the service using this command:

    # sudo service sshd restart

  3. If the issue persists even after restarting the service, open the /etc/hosts.allow file and change the sshd: ALL entry to:
    sshd: ALL: ALLOW

Web インターフェイスまたは SSH を使用して vMA にログインできない