An ESXi host fails to boot with the purple diagnostic screen error: Two filesystems with the same UUID have been detected
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An ESXi host fails to boot with the purple diagnostic screen error: Two filesystems with the same UUID have been detected

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Article ID: 342372

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • An ESXi host fails to boot successfully.
  • You see a purple diagnostic screen error similar to:

    Two filesystems with the same UUID have been detected. Make sure you do not have two ESXi installations.
     
  • The VMkernel log leading up to the outage contains an event similar to:

    Detected duplicate UUID file-systems on device ' naa.600508b1001c37d1e432b12f7b62f6bc:8' and ' naa.60060160f3542900122babfb5160e011:8'

    Note: For information on obtaining the VMkernel log, see Extracting the log file after an ESX or ESXi host fails with a purple screen error (1006796).


Environment

VMware ESXi 4.0.x Installable
VMware ESXi 4.1.x Embedded
VMware ESXi 4.0.x Embedded
VMware ESXi 4.1.x Installable

Cause

This issue occurs when a duplicate ESXi installation is detected on a disk presented to the ESXi host. Specifically, this issue occurs when two FAT-16 filesystems exposed to the ESXi installation have the same UUID. This may be the result of a broken mirror or due to previous activity cloning the disks which contain an ESXi installation.

Resolution

Note: This issue is most likely to be seen during startup of an ESXi host. It may be necessary to remove or un-present recently-added disks before troubleshooting can begin.

To resolve this issue, identify the two disks cited by ESXi as containing the duplicate filesystem UUID, and remove one of them:
  1. Collect the vmkernel-zdump from the ESXi host. For more information, see Collecting diagnostic information from an ESX or ESXi host that experiences a purple diagnostic screen (1004128).
     
  2. Extract the log file from the vmkernel-zdump file. For more information, see Extracting the log file after an ESX or ESXi host fails with a purple screen error (1006796).
     
  3. Use a editor or text file viewer to look at the log. For more information, see Editing configuration files in VMware ESXi and ESX (1017022).
     
  4. Identify the line similar to:

    Detected duplicate UUID file-systems on device 'DeviceName1' and 'DeviceName2'
     
  5. Identify the corresponding storage hardware or disk devices matching the devices from step 4. For more information, see Identifying disks when working with VMware ESX/ESXi (1014953).
     
  6. Disconnect one of the devices from step 5. For more information, consult your third-party hardware documentation.


Additional Information

Collecting diagnostic information from an ESX or ESXi host that experiences a purple diagnostic screen
Extracting the log file after an ESX or ESXi host fails with a purple screen error
Identifying disks when working with VMware ESXi/ESX
Editing configuration files in VMware ESXi and ESX
Simultaneous access to multiple ESXi installations on different drives causes the system to display panic messages
ESXi host displays an error and fails to boot when two ESXi installations are on the same system