vRealize Operations Manager Log Insight agent is unable to connect to vRealize Log Insight via SSL
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vRealize Operations Manager Log Insight agent is unable to connect to vRealize Log Insight via SSL

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Article ID: 319657

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • The pre-installed vRealize Operations Manager Log Insight agent is unable to connect to vRealize Log Insight via SSL if the server certificate can't be verified with web_chain.pem.
  • The vRealize Operations Manager certificate is not signed by the same CA as the vRealize Log Insight certificate.


Environment

VMware vRealize Operations Manager 7.5.x
VMware vRealize Operations Manager 7.0.x

Cause

The trusted certificate in vRealize Operations Manager is different from the one in the configured vRealize Log Insight instance.

Resolution

To resolve the issue, have the pre-installed vRealize Log Insight agent ignore the web_chain.pem file in vRealize Operations Manager.
  1. Log into the vRealize Operations Manager Primary node as root.
  2. Open /etc/sysconfig/liagentd in a text editor.
  3. Comment out the LIAGENT_SSL_CA_PATH=/data/vcops/user/conf/ssl/web_chain.pem line by putting a # at the beginning.
Example: #LIAGENT_SSL_CA_PATH=/data/vcops/user/conf/ssl/web_chain.pem
  1. Save and close the file.
  2. Restart the Log Insight agent service:
service liagentd restart
  1. Repeat steps 1-5 on all other vRealize Operations Manager nodes in the cluster.
Upgrading vRealize Operations Manager will reverse these changes.  If you upgrade vRealize Operations Manager, you will need to repeat these steps.