Harbor DNS resolution from the worker nodes is failing after re-deploying the Harbor instance
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Harbor DNS resolution from the worker nodes is failing after re-deploying the Harbor instance

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Article ID: 319526

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • You are unable to pull images from the harbor after re-deploying the harbor instance.

  • Harbor DNS resolution from the worker nodes is failing.

  • You have validated that worker nodes are able to resolve all other servers.



Environment

VMware PKS 1.x

Cause

This issue occurs due to the harbor deployment name stale entries on the primary/worker nodes. When you delete and re-install the Harbor deployment without selecting the upgrade clusters errand in PKS tile,  the harbor deployment name on the K8S nodes will not be updated, hence the nodes are trying to reach out to previous deployment name.

Resolution

To resolve this issue, apply either of the below options:

  • Update the latest harbor deployment name details under  /var/vcap/jobs/harbor-dns-aliases/dns/aliases.json on each primary/worker node.

    OR

  • Update the Harbor deployment name all nodes by running Upgrade cluster errand option from Ops manager.
    Note: Upgrading the clusters errand will re-create the nodes and may cause production impact if you are running the single pod applications on worker nodes.