vCenter Server Appliance email notifications are not sent when multiple email addresses are defined in an alarm action
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vCenter Server Appliance email notifications are not sent when multiple email addresses are defined in an alarm action

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Article ID: 313946

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

 

    • Alarm Actions are set to send an email notification to multiple email addresses using the semicolon (;) delimiter.
    • You see this alarm error:

      Alarm 'nameofalarm' on <vCenterServerFQDN> cannot send email to <emailaddress1>;<emailaddress2>;

       
    • In the /var/mail/root logs, you see entries similar to:
       

      Final-Recipient: RFC822; <contact1>@<domainname>;<contact2@<domainname>;
      X-Actual-Recipient: rfc822; “553 Invalid route address”@<vcsaname>.<domainname>
      Action: failed
      Status: 5.1.3



    Environment

    VMware vCenter Server Appliance 5.5.x
    VMware vCenter Server Appliance 6.5.x
    VMware vCenter Server Appliance 5.1.x
    VMware vCenter Server Appliance 6.0.x
    VMware vCenter Server Appliance 5.0.x

    Cause

    • VMware vCenter Server Appliance (VCSA) 6.5 only accepts comma (,)

    Resolution

    This is a known issue affecting vCenter Server Appliance.

    https://kb.vmware.com/kb/2150106    Unable to send a notification email from Alarm action if multiple emails are separated by semicolon in VCSA 6.5
    •     VMware vCenter Server Appliance (VCSA) 6.5 only accepts comma (,)

    Use comma (,) , and not semicolon (;) to seperate the multiple email addresses in your alarm action.


      Workaround:
      1. Create multiple email notification actions for each email address.
      2. Utilize an email distribution group to send email notifications.