Language :

After upgrading vRealize Orchestrator to 7.4 or any following version, NSX 6.x plug-in may not work. (55516)

 Click here to view full document
  • After upgrading vRealize Orchestrator from a version below 7.4 to a new version ( > 7.4), NSX 6.x plug-in may not work,  exception message is seen :
Exception thrown: 'org/apache/commons/beanutils/Converter'
  • Methods which uses commons-beanutils-1.9.3.jar Lib are affected, for example NSX plug-in
This issue occurs due to commons-beanutils-1.9.3.jar library being removed from vRealize Orchestrator 7.4. Some operations in NSX plug-in depends on this library.
Currently, there is no resolution. 
To workaround this issue, refer the steps:

Note: Take a snapshot / backup of vRO appliance
  1. Download the commons-beanutils-1.9.3.jar file attached to this article.
  2. Connect to vRO appliance using WinSCP or any similar file transfer client with root access. 
  3. Copy the file to the location /usr/lib/vco/app-server/deploy/vco/WEB-INF/lib/
  4. SSH to vRO as root user and change the owner of the copied jar:
chown vco:vco /usr/lib/vco/app-server/deploy/vco/WEB-INF/lib/commons-beanutils-1.9.3.jar
  1. Restart vRO server
  2. Apply steps 1-5 to all nodes in a cluster
For any upgrade from a vRO version before 7.4 please see: https://kb.vmware.com/s/article/55516
 
Ravi Kumar S
6/25/2019 6:09 PM
Cody Carlson