Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

VMware vCenter Site Recovery Manager service fails with the error: Panic: Assert Failed: "!vmKernelIp.empty()" @ d:/build/ob/bora-820150/srm/src/storage/vc/accessMapUtil.cpp:108 (2057469)

Symptoms

  • While performing a Test Recovery, the vCenter Site Recovery Manager (SRM) service on the recovery site fails.
  • You see the error:

    Panic: Assert Failed: "!vmKernelIp.empty()" @ d:/build/ob/bora-820150/srm/src/storage/vc/accessMapUtil.cpp:108

Cause

This issue occurs when:
  1. Network Attached Storage (NAS) appliances are configured for SRM using only IPv6, and IPv4 is disabled on the recovery site ESXi host(s).
  2. Array managers are created using only IPv6 addresses.

Resolution

This is a known issue affecting SRM 5.1.

To work around this issue, enable IPv4 on your recovery site ESXi hosts.

Additional Information

For related information, see Configuring IP Settings for ESXi in the vSphere 5.1 Installation and Setup Guide.

To be alerted when this article is updated, click Subscribe to Document in the Actions box.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 2 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 2 Ratings
Actions
KB: