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Log Insight email test fails with the exception: Unknown SMTP host (2053560)

Symptoms

    • Attempting to send a test email from the Log Insight administration interface fails with the error:

      Unknown SMTP host

    • The Log Insight runtime.log file contains java.net.UnknownHostException when sending a test email. For example:

      [yyyy-mm-dd hh:mm:ss.nnnn+tz] [http-443-2 INFO /n.n.n.n] [com.vmware.loginsight.web.actions.settings.AbstractConfigurationActionBean] [Failed to send test email]
      ...
      Caused by: java.net.UnknownHostException: smtp.server.hostname.example.com
      at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
      at java.net.SocksSocketImpl.connect(Unknown Source)
      at java.net.Socket.connect(Unknown Source)
      at java.net.Socket.connect(Unknown Source)
      at com.sun.mail.util.SocketFetcher.createSocket(SocketFetcher.java:319)


    • Attempting to resolve the hostname from the Log Insight virtual appliance console fails. For example:

      # ping smtp.server.hostname.example.com
      ping: unknown host smtp.server.hostname.example.com

    Cause

    This issue occurs because VMware vRealize Log Insight (formerly known as VMware vCenter Log Insight) is attempting to contact the SMTP server to send a test email, but a DNS resolution of the configured SMTP server's hostname does not complete successfully. Log Insight may have been configured with incorrect/misconfigured DNS servers or an incorrect SMTP server.

    Resolution

    To resolve this issue:
    • If the SMTP server is incorrect, specify the name of the correct SMTP server. For more information, see the Configure Log Insight section of the vCenter Log Insight Installation and Administration Guide.

    • If the DNS servers are incorrect, specify the IP address(es) of the correct DNS servers. For more information, see the Deploy the Log Virtual Appliance section of the vCenter Log Insight Installation and Administration Guide.

    • If the DNS servers are correct, but are not resolving the SMTP server correctly, there may be a problem between the Log Insight virtual appliance and the DNS servers, such as a firewall or other third-party network configuration.

    Additional Information

    For full product documentation, see the VMware vCenter Log Insight Documentation page.

    Request a Product Feature

    To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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