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Adding an extent to a volume formatted with VMFS 5 fails (2045465)

Symptoms

When attempting to add an extent to a VMFS volume, the device does not show up when you click the Increase button in the Add Storage wizard.
 
This issue occurs when:
  • The VMFS volume is formatted as VMFS5
  • The LUN being used as the extent is not of the same type as the LUN backing the original volume. For example, one is a solid state (SSD/Flash) LUN, while the other is not.

Cause

This is an expected behavior and is by design. SSD and non-SSD storage should not be combined as extents due to their differing performance characteristics.

Note: This issue occurs only with VMFS5 volumes and not with VMFS3 volumes.

Resolution

When working with extents, use only the same type of storage LUNs. For example, SSD disks should only be combined with other SSD disks as extents.

If the two LUNs are of the same type, but are not detected, see ESXi fails to identify a device as SSD (2008938).

In ESXi 5.x, you can confirm that a LUN is detected as a solid state device from the command line:

  1. Connect to the host using SSH or the Local Tech Support mode command prompt. For more information, see Using Tech Support Mode in ESXi 4.1 and ESXi 5.x (1017910).
  2. Note the unique NAA ID of the LUN that you want to check. If you do not already have the unique NAA identifier of the LUN, see Identifying disks when working with VMware ESX/ESXi (1014953).
  3. Run this command:

    # esxcli storage core device list --device=NAA |grep SSD

    Where NAA is the NAA ID of the LUN noted in Step 2.

    You should see an output similar to:

    Is SSD: true

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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