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VMware vCenter 5.1.x fails to start with error: Failed to add LDAP entry (2044680)

Symptoms

  • VMware vCenter 5.1.x fails to start.
  • vpxd log file displays error similar to the following:

    error 'win32vpxLdap_win32'] [LDAP Client] Failed to add LDAP entry cn=d6cc6fd2-bb66-4fe9-9892-4a3a0c93b91d,ou=Instances,dc=virtualcenter,dc=vmware,dc=int: 0×68 (The object already exists.)

    or

    error 'win32vpxLdap_win32'] [LDAP Client] Failed to add LDAP entry cn=H4416-8EJ8K-58342-0T0AP-A8K05,ou=Licenses,ou=Licensing,dc=virtualcenter,dc=vmware,dc=int: 0x68 (The object already exists.)

NoteThe CN value referenced in the vpxd log will be unique to your vCenter installation.

Cause

This issue most likely occurs due to a stale ADAM database entry.
 

Resolution

  1. On the vCenter Server, go to Start > Administrative Tools > ADSI Edit. The ADAM editor opens.
  2. Right-click ADSI Edit at the root level and click Connect to. The Connection Settings window appears.
  3. For Connection Point, click Select or type a Distinguished Name or Naming Context and type dc=virtualcenter,dc=vmware,dc=int.
  4. Under Computer, click Select or type a domain or server.
  5. Click localhost from the dropdown
    or
    Type localhost:389
  6. Click OK.
  7. Under the OU=Instances, find the CN:
    cn=d6cc6fd2-bb66-4fe9-9892-4a3a0c93b91d
    Click on this CN entry. The right-side pane is empty.
  8. Delete this CN entry.

Note: In your environment, the error message in the vpxd logs will be a different CN  number than what is shown above. Make sure you search for that particular string. 

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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