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vSphere Data Protection (VDP) appliance licensing logic (2044613)

Symptoms

  • When starting a vSphere Data Protection (VDP) appliance, the services do not start.
  • In the /data01/cur/gsan.log file, you see messages which indicate that the license grace period has expired and no valid license is found:

    2013/01/04-07:29:23.08858 {0.0} [runlevelbeat]  runlevelmanager::taskrunner::isreadyfornextlevel licensevalidator is not ready for next level
    2013/01/04-07:29:25.77652 {0.0} [licensevalidator:114]  ERROR: <0948> license grace period expired 17 days ago (Mon Dec 17 19:47:16 2012)
    2013/01/04-07:29:25.77662 {0.0} [licensevalidator:114]  FATAL ERROR: <0001> licensevalidator::body no valid license found

Purpose

This article provides information about the licensing logic used by the vSphere Data Protection (VDP) appliance.

Cause

When the vSphere Data Protection (VDP) appliance is deployed, there is an evaluation license on the gsan service which is valid for 30 days. The VDP appliance looks for a valid ESXi host license, and it accepts any licenses except "esxExpress" (Essential Edition) or "esxExpress.vram" (Essential Edition VRAM).

The gsan license check should only occur on booting the VDP appliance. If the appliance has been running for over 30 days and is then rebooted, and if the services fail to start on reboot, this may be the root cause.

If the VDP appliance is not associated to an ESXi host which has a valid license, the gsan service will not start when the gsan's evaluation license expires after 30 days. This prevents other services from starting as well. As stated above, the gsan service should only attempt to start on reboot.

This issue can also occur if there is a space in the vCenter Server account password, which causes the VDP appliance to fail authenticating to vCenter Server. This occurs only when the VDP appliance is rebooted more than 30 days after it is deployed.

Resolution

To resolve this issue:
  • If you are experiencing this issue due to an invalid license, provide a valid license for the ESXi host that is associated to the VDP appliance.

    Note: Licenses which are not valid/excluded are:
    • "esxExpress" (Essential Edition)
    • "esxExpress.vram" (Essential Edition VRAM)

  • If you are experiencing this issue due to a space in the in the vCenter Server account password, change the vCenter Server password to a string without a space.

Additional Information

When the gsan log shows the evaluation license countdown, this means that the ESXi host which the VDP is associated to is not licensed, and there are a limited number of days before the gsan license fails. (The log indicates the number of days remaining.)

When the gsan service starts up, one of its initial tasks is to do a license check. Possible points of failure in the license check procedure are:
  • If the VDP appliance cannot communicate with the vCenter Server, it cannot determine the ESXi host and its associated license.
  • If the ESXi host on which the VDP appliance resides does not have a valid license (or is licensed with one of the excluded licenses), VDP allows the gsan to run for evaluation period of 30 days, and then fails.

Update History

02/14/2013 - Added information on vCenter Server password issue

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