Knowledge Base

|
Unable to search the inventories of other vCenter Server systems while in linked mode (2044444)
Symptoms
- In linked mode, you are unable to search for the inventories of other vCenter Server systems
- This issue occurs even if you log in as a Local Administrator and Domain Administrator and the Domain User account has Administrator rights to all vCenter Server systems
- This issue persists even if you create a new AD user and have given it administrator rights to all vCenter Server systems
- This issue occurs when:
-
- You have broken the linked mode and rejoined in linked mode successfully
- You have uninstalled and reinstalled vCenter Server
Cause
If the vSphere Client is connected to a vCenter Server system that is part of a connected group in vCenter Linked Mode, you can search the inventories of all vCenter Server systems in that group. You can view and search only for inventory objects that you have permission to view. Because the search service queries Active Directory for information about user permissions, you must be logged in to a domain account to search all vCenter Server systems in linked mode. If you log in using a local account, searches return results only for the local vCenter Server system, even if it is joined to other servers in linked mode.
Resolution
- Log in to the vSphere Client as an administrator.
- Select the vCenter Server.
- Click the Permissions tab.
-
Right-click Domain\user under User/Group and click Properties.
-
Ensure that the role for this user is Administrator and the Propagate option is selected.
If you do not have a Domain Administrator user, create a domain user with Administrator privileges:
- Right-click the vCenter Server object and click Add Permission.
- Click Add.
- From the dropdown, select your domain.
- Select the user from the list and then click Add.
- Click OK.
- In the Assigned Role dropdown, select Administrator.
- Select the Propagate to Child Objects option.
- Click OK.
To ensure that the Inventory Service is running as a Domain Administrator:
- Click Start > Run, type services.msc and click OK.
- Stop the vCenter Inventory Service. For more information, see Stopping, starting, or restarting vCenter services (1003895).
- Double-click vCenter Inventory Service.
- Click the Log On tab.
-
Select This Account and type the name of the account in the DOMAINNAME\accountname format.
Alternatively, click Browse and find the correct account. - Enter the appropriate password for the account in the Password and Verify Password fields.
- Click OK.
- Start the vCenter Inventory Service. For more information, see Stopping, starting, or restarting vCenter services (1003895).
See Also
Request a Product Feature
- Updated:
- Categories:
- Languages:
- Product Family:
- Product(s):
- Product Version(s):

