Knowledge Base

The VMware Knowledge Base provides support solutions, error messages and troubleshooting guides
 
Search the VMware Knowledge Base (KB)   View by Article ID
 

Restoring a virtual machine using vSphere Data Protection fails with a E22297 error (2044407)

Symptoms

  • Cannot restore a virtual machine using vSphere Data Protection (VDP)
  • Restoring a virtual machine using VDP fails
  • You see the error:

    E22297:Request to restore is rejected because the plug-in doesn't support it, the plug-in is disabled, the client is disabled, or the client is not activated

Cause

This issue occurs because the virtual machine disk (vmdk) type is configured as Independent. In this case, the changes to the virtual machine disk is not saved because the snapshots do not affect the state of an independent disk.

For more information, see:

To confirm this issue:

  1. Connect to the VDP appliance using SSH.

    Note: The default username/password for a VDP appliance is root/changeme.

  2. Run this command:

    # cd /mnt/axion/vCenter-name/VirtualMachines/VM-name

    Where:

    vCenter-name is the name of your vCenter Server
    VM-name is the name of the virtual machine that you are attempting to restore

  3. Open the configuration.xml file located within this directory using a text editor.

    This file contains the configuration details of the virtual machine.

  4. Locate the entry similar to:

    <vmDiskInfoList numDisks="1">


    <vmDiskInfo fileBackingClass="com.vmware.vim25.VirtualDiskFlatVer2BackingInfo" datastoreUrl="ds:///vmfs/volumes/5049e006-b303df5a-f7f8-002219652c75/" diskMode="independent_persistent" compatibilityMode
    ="NA" vmdkFilename="[DR13 - VM1] PROD - Supervision/Supervision.vmdk" vmdkBaseFile="[DR13 - VM1] PROD - Supervision/Supervision.vmdk" capacityInKB="24117248" srcOrdinal="-1" backup="false" label="Hard disk 1" diskKey="2000" ordinal="1" datastore="DR13 - VM1" prevCapacityInKB="24117248" thinProvisioned="true" baseDatastore="DR13 - VM1" prevChangeID="" />

    </vmDiskInfoList>

    In this entry, you can see that the backup tag is set to false and, therefore, the virtual machine disk is not affected by snapshots.

Resolution

To resolve this issue, change the disk type of the virtual machine to Dependent.
 
For information on changing the disk type, see Change the Virtual Disk Configuration in the vSphere Client.
 
Note: After changing the disk type, ensure to perform a test backup and restore of the virtual machine to check if it is working properly.

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

  • 0 Ratings

Did this article help you?
This article resolved my issue.
This article did not resolve my issue.
This article helped but additional information was required to resolve my issue.
What can we do to improve this information? (4000 or fewer characters)
  • 0 Ratings
Actions
KB: