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Uploading logs using the vCenter Support Assistant fails with the error: unable to find valid certification path to requested target (2044202)

Symptoms

  • Cannot upload logs using the vCenter Support Assistant 5.1
  • Uploading logs using the vCenter Support Assistant 5.1 fails
  • You see the error:
An error while uploading occurred:
An error occurred while uploading.

Additional information:

Failure code: 650
Failure reason: sun.security.validator.ValidatorException: PKIK path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target.
  • Running the built-in diagnostics passes for all checks.

Cause

This issue occurs if the vCenter Support Assistant does not have the correct proxy settings to communicate outside your local area network and to the required public addresses, https://supportassistant.vmware.com/ and https://*.nirvanix.com/.

Resolution

To resolve this issue:

  1. Open an SSH/Putty session to the IP address of the vCenter Support Assistant appliance.
  2. Open the environment file using a text editor. For example:

    vi /etc/environment

  3. Add a line similar to :

    https_proxy= https://yourproxy. yourdomain.com :3128

    Note: Edit this entry to suit your network proxy settings.

  4. Reboot the vCenter Support Assistant appliance.
  5. Open the vSphere Client to vCenter Server with which the Support Assistant is registered and ensure you see it under Solutions and Applications.
  6. Attempt to upload the logs to a new or existing Support Request. The upload should now be successful.

Additional Information

Note: If, for some reason, you are unable to upload logs using the vCenter Support Assistant, you can upload the logs through My VMware or using the ftpsite.vmware.com site.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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