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Newly modified screen set runs slowly after adding commas in modified fields in VMware Service Manager 9.x (2044041)

Symptoms

After modifying a screen set in VMware Service Manager 9.x, you experience these symptoms: 
  • When being opened, the screen runs very slowly.
  • Opening the screen locks up Service Manager controls.
  • Fields that are visible on-screen develop a series of commas that double each time you open the screen.

Cause

This issue is caused by an abnormality in the screen's htm code. The abnormality may include, but is not limited to, duplicates of any given field. In some cases, by deleting and re-adding the same field on a screen set, a duplicate of that field is entered into the zone on the bottom of the htm, which causes a data loop when the screen is opened.

Resolution

To resolve this issue: 
  1. Open the screen in Designer.
  2. Click Save as to back up your current screen set, if necessary. 
  3. Click Load Default to load the default screen set for this screen type.
  4. Add your custom fields back and re-customize the screen set.

The screen set should now run at a normal speed.

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