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Logging in to the vSphere Data Protection Restore Client fails with the error: Cannot locate login client in VDP (2042092)

Symptoms

  • You cannot log in to the vSphere Data Protection Restore Client.
  • When logging in to the vSphere Data Protection Restore Client, you see the error:

    Login failed. Cannot locate login client (VM_IP_address) in VDP.

Cause

This issue can occur in these situations:
  • If virtual machine from which the vSphere Data Protection Restore Client was launched has never been added to a backup job on the VDP appliance used in the URL to access the Restore Client.

  • If the network appliance is using network address translation (NAT) and is sending all VDP traffic through a proxy/firewall.

  • If the user did not install VMware Tools in the virtual machine trying to access the portal.
  • If using Windows Server running vCenter with Microsoft SQL Server 2008 RTM (Version 10.0.1600.22(x64)). There is a known issue when a complex query is run that contains aggregate functions, join functions and distinct functions in sub queries. This may cause the File Level Restore (FLR) to return incorrect results and display the error:

    Login failed. Cannot locate login client (VM_IP_address) in VDP.
  • If there are multiple virtual machines with the same IP address in the vCenter Server inventory.

Resolution

To resolve this issue, log in to a virtual machine where a backup job has been created and run to allow for file level restores.

If the issue is due to a firewall/proxy, exclude all VDP traffic from using this route.

If the issue is due to missing VMware Tools, another backup with the VMware Tools is not required. Simply installing VMware Tools in the virtual machine corrects the authentication error.

For more information, see the VMware vSphere Data Protection Documentation.

If the issue is due to Microsoft SQL version, upgrading to Microsoft SQL Server 2008 R2 SP2 should resolve the issue.
For more information, see List of the bugs that are fixed in SQL Server 2008 R2 Service Pack 2.

See Also

Update History

03/31/2014 - Added "If using Windows Server running vCenter with Microsoft SQL Server 2008 RTM (Version 10.0.1600.22(x64)). There is a known issue when a complex query is ran that contains aggregate functions, join functions and distinct functions in sub queries. This may cause the File Level Restore (FLR) to return incorrect results and throws the error Login failed. Cannot locate login client (VM_IP_address) in VDP. If there are multiple virtual machines with the same IP address in the vCenter Server inventory. 03/31/2014 - Added If the issue is due to Microsoft SQL version, upgrading to Microsoft SQL Server 2008 R2 SP2 should resolve the issue. For more information, see List of the bugs that are fixed in SQL Server 2008 R2 Service Pack 2.

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