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Old jobs continually reappear in the Resque Queue in Socialcast On Premise v2 (2041773)

Symptoms

When observing the queue via Resque Web, you experience these symptoms:  
  • Queue is large, and jobs are being processed by Workers.
  • Queue sizes eventually reduce and/or return to 0.
  • After an arbitrary time has elapsed (usually < 1 hour), queue numbers quickly return to the same size as before.
  • When inspecting the /var/log/redis/redis.log file, you observe the following error message repeated one or many times:

    * 100 changes in 300 seconds. Saving...
    # Can't save in background: fork: Cannot allocate memory

  • Duplicate e-mail digests & notifications are being received by users.

Cause

Redis performs a snapshot of the dataset every 5 minutes by default, provided there have been a minimum of 10 changes in that time. The snapshot is performed using the BGSAVE command, which triggers a process fork. When the current memory size (RAM + Swap) of the Redis process is greater than the currently available RAM (excluding swap), the fork request is denied.

Resolution

If this issue occurs during the normal operation of the community, the only long-term fix for this issue is to allocate more RAM to the Queue Server node. If this occurs following abnormal operation/downtime of the Search Server or Background Workers etc, then temporary measures to allow processing of the current queue will be sufficient.

To clear the Redis dataset and reduce the resulting memory usage, see  Manually purge and reset the Redis Queue Server dataset in Socialcast On Premise (2041218).
 
After performing these steps, the queue will be cleared and the memory usage for Redis returned to normal. The /var/log/redis/redis.log will now report successful BGSAVE operations, such as:
* 10 changes in 300 seconds. Saving...
* Background saving started by pid 8865
* DB saved on disk
* Background saving terminated with success


See Also

Request a Product Feature

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