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VMware VirtualCenter Single Sign On and Lookup services fail to start after upgrading to vCenter Server 5.1 (2041528)

Symptoms

  • VMware VirtualCenter Single Sign On (SSO) and Lookup services fail to start after upgrading to vCenter Server 5.1. 
  • You see the errors:
    • Error 29942: Could not start service vCenter Single Sign On

      Or

    • Error 20010: Failed to Configure LookupService

  • The SSO Catalina logs (located in C:\Program Files\VMware\Infrastructure\SSOServer\logs\catalina*) contain entries similar to:

    SEVERE [WrapperSimpleAppMain] org.apache.catalina.startup.Bootstrap.initClassLoaders Class loader creation threw exception
    java.lang.NoSuchFieldError: threadAllocatedMemorySupport
    at sun.management.VMManagementImpl.initOptionalSupportFields(Native Method)
    at sun.management.VMManagementImpl.<clinit>(VMManagementImpl.java:47)
    at sun.management.ManagementFactory.<clinit>(ManagementFactory.java:468)
    at java.lang.management.ManagementFactory.getPlatformMBeanServer(ManagementFactory.java:504)
    at org.apache.catalina.startup.Bootstrap.createClassLoader(Bootstrap.java:158)
    at org.apache.catalina.startup.Bootstrap.initClassLoaders(Bootstrap.java:91)
    at org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:227)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:425)


  • The Lookup service configuration fails.
  • The discover-is.log logs show errors similar to:

    ERROR: Could not connect to HTTP invoker remote service at [https://localhost:7444/ims/CommandServer]; nested exception is java.net.ConnectException: Connection refused: connect

Cause

This issue occurs if the Java Run-Time (JRE) is corrupt. VMware vCenter Server and its services require JRE.

Resolution

 Note: Stop  java.exe process if running in Task Manager.

To resolve the issue, overwrite the existing JRE folder (located in C:\Program Files\vmware\infrastructure\JRE) with a working copy from an existing install, or from the install media of the existing folder files.
 
To collect JRE folder from Installer:
  1. Launch the installer for SSO.
  2. Wait for the wizard to load. Do not click  next.
  3. Run %temp%.
  4. Search for jre.zip.
  5. Extract contents from jre.zip and copy to  C:\Program Files\vmware\infrastructure\JRE.

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

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